toolchain/gcc: add elf2flt to dependencies
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 11 Sep 2013 12:12:06 +0000 (09:12 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 12 Sep 2013 22:08:04 +0000 (00:08 +0200)
Add host-elf2flt to the gcc common dependencies so we get it built after
binutils but before gcc/uclibc since it's required for all packages and
in some uClibc configuration scenarios.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gcc/gcc.mk

index 6654b5167464bfa1fb72e00a481f144ebe670266..157357cd783105ad0b38cb6e0dbfeb95018898ba 100644 (file)
@@ -86,7 +86,8 @@ endef
 HOST_GCC_COMMON_DEPENDENCIES = \
        host-binutils \
        host-gmp \
-       host-mpfr
+       host-mpfr \
+       $(if $(BR2_BINFMT_FLAT),host-elf2flt)
 
 HOST_GCC_COMMON_CONF_OPT = \
        --target=$(GNU_TARGET_NAME) \