blackfin: 2012R1 toolchain is gone, remove kludges
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 17 Jun 2014 22:23:19 +0000 (19:23 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 18 Jun 2014 12:01:03 +0000 (14:01 +0200)
Remove ADI toolchain 2012R1 package kludges since that version is gone
since the last bump.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libtirpc/Config.in
package/openpgm/Config.in
package/popt/popt.mk
package/rpcbind/Config.in
package/zeromq/Config.in
package/zyre/Config.in

index a6759e70d31bad9b948b325c3622b010a3d5bab0..a8e6dd386a049ac6d89aa5afefa0dee1febfcd97 100644 (file)
@@ -5,8 +5,7 @@ config BR2_PACKAGE_LIBTIRPC
        # don't need to propagate this dependency to reverse
        # dependencies of libtirpc for which native RPC support can be
        # used instead of libtirpc.
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          Libtirpc is a port of Sun's Transport-Independent RPC
@@ -15,6 +14,5 @@ config BR2_PACKAGE_LIBTIRPC
          http://sourceforge.net/projects/libtirpc/
 
 comment "libtirpc needs a toolchain w/ threads"
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        depends on !BR2_TOOLCHAIN_HAS_THREADS
index a9d0cc84dcf6e8b57dbdcc741c2f5196f286e52e..dc66367b41d8705f84d4ad400612b31e568681ca 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_OPENPGM
        depends on !BR2_avr32
        depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1
        depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_INET_IPV6
        depends on BR2_USE_WCHAR
index 9f2d070d890748ed58abac0c21c72a9721fe18c2..f3ef43f344dbdc24567ec77d2f08891372fae852 100644 (file)
@@ -16,7 +16,7 @@ POPT_CONF_ENV = ac_cv_va_copy=yes
 # The external Blackfin toolchains have <glob.h>, but not all the
 # necessary uClibc options for glob functions, so we force disable the
 # usage of the glob functions for these toolchains.
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1)$(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2)$(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1),y)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2)$(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1),y)
 POPT_CONF_ENV += ac_cv_header_glob_h=no
 endif
 
index e02fb950e2f4eccdd9ba207128b84e0a067d5b03..2a79bdc69c9fae2f032f64bb17aa59d5776a11ab 100644 (file)
@@ -6,8 +6,7 @@ config BR2_PACKAGE_RPCBIND
        select BR2_PACKAGE_LIBTIRPC
        # uClibc toolchains provided by ADI don't have AI_ADDRCONFIG
        # support, needed for libtirpc
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        # fork()
        depends on BR2_USE_MMU
        help
@@ -15,7 +14,6 @@ config BR2_PACKAGE_RPCBIND
          into universal addresses.
 
 comment "rpcbind needs a toolchain w/ threads"
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        depends on !BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_MMU
index a02f4ab474b1ee4ccf2a376dc12ce693023cd06a..778a503e02bd006ea1fce9cfc7f97cc809ccc1cb 100644 (file)
@@ -34,7 +34,6 @@ config BR2_PACKAGE_ZEROMQ_PGM
        depends on !BR2_avr32 # openpgm
        depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # openpgm
        depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # openpgm
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1 # openpgm
        select BR2_PACKAGE_OPENPGM
        help
          Add support for Pragmatic General Multicast protocol (RFC 3208)
index 31e1d6f0aea17891feade510c82e010905555a73..fbfc6f940a8088f09f083414607c3675042812d6 100644 (file)
@@ -8,8 +8,7 @@ config BR2_PACKAGE_ZYRE
        depends on BR2_USE_MMU # filemq -> czmq
        # uClibc toolchains provided by ADI don't have AI_ADDRCONFIG
        # support, needed by filemq -> czmq
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        select BR2_PACKAGE_FILEMQ
        help
          An open-source framework for proximity-based peer-to-peer
@@ -19,7 +18,6 @@ config BR2_PACKAGE_ZYRE
 
 comment "zyre needs a toolchain w/ C++, IPv6, largefile, wchar, threads"
        depends on BR2_USE_MMU
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_LARGEFILE \
                && BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS)