ffmpeg: add options for postproc/swscale
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 7 Oct 2010 07:54:00 +0000 (09:54 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 7 Oct 2010 07:54:00 +0000 (09:54 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/ffmpeg/Config.in
package/multimedia/ffmpeg/ffmpeg.mk

index fb6591baf8418743386a599ac9f21dc7b6138a77..2f9499101a9d1e9712566b9149ea46f98dd2d64c 100644 (file)
@@ -47,6 +47,17 @@ config BR2_PACKAGE_FFMPEG_FFSERVER
        help
          FFserver is a streaming server for both audio and video.
 
+config BR2_PACKAGE_FFMPEG_POSTPROC
+       bool "Build libpostproc"
+       depends on BR2_PACKAGE_FFMPEG_GPL
+       help
+         Postproc is a library of video postprocessing routines.
+
+config BR2_PACKAGE_FFMPEG_SWSCALE
+       bool "Build libswscale"
+       help
+         Swscale is a library of video scaling routines.
+
 config BR2_PACKAGE_FFMPEG_ENCODERS
        string "Enabled encoders"
        default "all"
index 4e6924c3d550fc909dd9995e027d7ca4ced5fa68..959efa39b2d97985e544be1f4e4e4938158b000a 100644 (file)
@@ -13,8 +13,6 @@ FFMPEG_CONF_OPT = \
        --prefix=/usr           \
        --enable-shared         \
        --disable-avfilter      \
-       --disable-postproc      \
-       --disable-swscale       \
        --disable-vhook         \
 
 ifeq ($(BR2_PACKAGE_FFMPEG_GPL),y)
@@ -49,6 +47,18 @@ else
 FFMPEG_CONF_OPT += --disable-ffserver
 endif
 
+ifeq ($(BR2_PACKAGE_FFMPEG_POSTPROC),y)
+FFMPEG_CONF_OPT += --enable-postproc
+else
+FFMPEG_CONF_OPT += --disable-postproc
+endif
+
+ifeq ($(BR2_PACKAGE_FFMPEG_SWSCALE),y)
+FFMPEG_CONF_OPT += --enable-swscale
+else
+FFMPEG_CONF_OPT += --disable-swscale
+endif
+
 ifneq ($(call qstrip,$(BR2_PACKAGE_FFMPEG_ENCODERS)),all)
 FFMPEG_CONF_OPT += --disable-encoders \
        $(foreach x,$(call qstrip,$(BR2_PACKAGE_FFMPEG_ENCODERS)),--enable-encoder=$(x))