Revert "linux: fix the KCONFIG_GET_OPT calls to be inside a BR2_LINUX_KERNEL test"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:15:45 +0000 (19:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:15:45 +0000 (19:15 +0100)
This reverts commit 4ad1ea59a59f951fad072dcb19429e6f468abf05. The
whole host-lzop optional dependency logic cannot work, since the
configuration file will only be known after the kernel sources are
extracted, if an internal kernel defconfig is used, which is quite
common.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 680279c9e689c289b54e3eb636871ceae35806f0..91a5fb8d814229bc2a08103edc2e27cb2e75c756 100644 (file)
@@ -170,6 +170,7 @@ ifeq ($(BR2_LINUX_KERNEL),y)
 ifeq ($(wildcard $(KERNEL_SOURCE_CONFIG)),)
 $(error Configuration file '$(KERNEL_SOURCE_CONFIG)' not found.)
 endif
+endif
 
 ifeq ($(call KCONFIG_GET_OPT,CONFIG_KERNEL_LZO,$(KERNEL_SOURCE_CONFIG)),y)
 LINUX_DEPENDENCIES += host-lzop
@@ -177,7 +178,6 @@ endif
 ifeq ($(call KCONFIG_GET_OPT,CONFIG_RD_LZO,$(KERNEL_SOURCE_CONFIG)),y)
 LINUX_DEPENDENCIES += host-lzop
 endif
-endif
 
 define LINUX_CONFIGURE_CMDS
        $(INSTALL) -m 0644 $(KERNEL_SOURCE_CONFIG) $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig