package/libgit2: Bump to version 1.0.0
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Fri, 17 Apr 2020 07:28:01 +0000 (09:28 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 17 Apr 2020 08:58:07 +0000 (10:58 +0200)
This version changes the required dependencies as well as introducing
new bundled ones...

- Switch to the tarball released by upstream.
- Start depending on httpparser, instead of using the bundled one.
- Force using regcomp instead of using a bundled pcre.
- Add license for a bundled wildmatch and sha1.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
[yann.morin.1998@free.fr: reorder licenses; two spaces in hash file.]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libgit2/Config.in
package/libgit2/libgit2.hash
package/libgit2/libgit2.mk

index 53ba4d42456b827f8b9f5190be5a9b4aa8f130d8..a6a9728ff05ed84455bc53dc398b9eda227b3ef0 100644 (file)
@@ -1,5 +1,7 @@
 config BR2_PACKAGE_LIBGIT2
        bool "libgit2"
+       depends on !BR2_STATIC_LIBS # libhttpparser
+       select BR2_PACKAGE_LIBHTTPPARSER
        select BR2_PACKAGE_ZLIB
        help
          libgit2 is a portable, pure C implementation of the Git core
@@ -7,3 +9,6 @@ config BR2_PACKAGE_LIBGIT2
          allowing to build Git functionality into your application.
 
          https://github.com/libgit2/libgit2
+
+comment "libgit2 needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
index d4912c0327bee853868e05ca0c88e33352983aa5..6e977a97e022e990972d5c2a6649ae05fface309 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 30f3877469d09f2e4a21be933b4e2800560d16646028dd800744dc5f7fb0c749  libgit2-0.28.4.tar.gz
-sha256 d9a8038088df84fde493fa33a0f1e537252eeb9642122aa4b862690197152813  COPYING
+sha256  6a1fa16a7f6335ce8b2630fbdbb5e57c4027929ebc56fcd1ac55edb141b409b4  libgit2-1.0.0.tar.gz
+sha256  afc8bde99ba630012107c25d3c42dde628ec5f0cd3f428131f7e3a0f7d58ff42  COPYING
index 909fcb83f04f8985e5ee50b2aae48703c88cbacd..46cc4286c6755883e34a74ae3b75ea1828bb60cb 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-LIBGIT2_VERSION = 0.28.4
-LIBGIT2_SITE = $(call github,libgit2,libgit2,v$(LIBGIT2_VERSION))
-LIBGIT2_LICENSE = GPL-2.0 with linking exception
+LIBGIT2_VERSION = 1.0.0
+LIBGIT2_SITE = https://github.com/libgit2/libgit2/releases/download/v$(LIBGIT2_VERSION)
+LIBGIT2_LICENSE = GPL-2.0 with linking exception, MIT (sha1), wildmatch license (wildmatch)
 LIBGIT2_LICENSE_FILES = COPYING
 LIBGIT2_INSTALL_STAGING = YES
 
@@ -14,9 +14,11 @@ LIBGIT2_CONF_OPTS = \
        -DUSE_GSSAPI=OFF \
        -DBUILD_CLAR=OFF \
        -DUSE_ICONV=ON \
+       -DREGEX_BACKEND=regcomp \
+       -DUSE_HTTP_PARSER=system \
        -DTHREADSAFE=$(if $(BR2_TOOLCHAIN_HAS_THREADS),ON,OFF)
 
-LIBGIT2_DEPENDENCIES = zlib
+LIBGIT2_DEPENDENCIES = zlib libhttpparser
 
 # If libiconv is available (for !locale toolchains), then we can use
 # it for iconv support. Note that USE_ICONV=ON is still correct even