package/gstreamer1/gst1-plugins-bad: add bluez plugin option
authorAdam Duskett <Aduskett@gmail.com>
Thu, 9 May 2019 22:46:24 +0000 (18:46 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 May 2019 19:22:35 +0000 (21:22 +0200)
Currently there is no explicit way to turn the bluez plugin on or off.
Create a menu entry allowing users to disable or enable the plugin.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
[Thomas: really replicate all dependencies of BR2_PACKAGE_BLUEZ_UTILS]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 35d6bddd05cf6801c73c4811cccf2f13c7105a6f..b1232af16e76fd3a073efaca96479fc12bbac6c5 100644 (file)
@@ -308,6 +308,20 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ASSRENDER
        bool "assrender"
        select BR2_PACKAGE_LIBASS
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_BLUEZ
+       bool "bluez"
+       depends on !BR2_STATIC_LIBS # bluez_utils
+       depends on BR2_USE_WCHAR # bluez_utils
+       depends on BR2_TOOLCHAIN_HAS_THREADS # bluez_utils
+       depends on BR2_USE_MMU # bluez_utils
+       select BR2_PACKAGE_BLUEZ_UTILS
+       help
+         Bluetooth audio A2DP/AVDTP sink, AVDTP source plugin
+
+comment "bluez plugin needs a toolchain w/ wchar, threads, dynamic library"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_BZ2
        bool "bz2"
        select BR2_PACKAGE_BZIP2
index ad1adbc3850161efc563b0baad537ea987bd9740..32edde4901ea8d784678cef7f6937a9c58818010 100644 (file)
@@ -83,7 +83,7 @@ GST1_PLUGINS_BAD_DEPENDENCIES += orc
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-orc
 endif
 
-ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_BLUEZ),y)
 GST1_PLUGINS_BAD_DEPENDENCIES += bluez_utils
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-bluez
 else