at91bootstrap: allow specification of a custom patch directory
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 2 Feb 2012 22:29:26 +0000 (23:29 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 2 Feb 2012 22:42:34 +0000 (23:42 +0100)
Fixes bug #4664.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
boot/at91bootstrap/Config.in
boot/at91bootstrap/at91bootstrap.mk

diff --git a/CHANGES b/CHANGES
index b10fff801d41e2782ec753fc64b569c58c6225eb..dfc7d7122c936dd198ab3d53112a08c05c15edd6 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -59,6 +59,7 @@
        #3403: libgpg-error: bump to version 1.10
        #3409: libgpg-error: download from gnupg.org
        #3421: nano: make tiny flag optional
+       #4664: Cannot patch AT91Bootstrap
        #4700: setlocalversion not working for combination svn/ubuntu 11.10...
 
 2011.11, Released November 30th, 2011:
index b232b3b78e451e55cb4c101954c670df365ac915..9cbaf81eef0848d096f2f1b12e0b896ef812dce9 100644 (file)
@@ -10,6 +10,15 @@ config BR2_TARGET_AT91BOOTSTRAP
 
 if     BR2_TARGET_AT91BOOTSTRAP
 
+config BR2_TARGET_AT91BOOTSTRAP_CUSTOM_PATCH_DIR
+       string "custom patch dir"
+       help
+         If your board requires custom patches, add the path to the
+         directory containing the patches here. The patches must be
+         named at91bootstrap-<version>-<something>.patch.
+
+         Most users may leave this empty
+
 config BR2_TARGET_AT91BOOTSTRAP_BOARD
        string "Bootstrap board"
        default ""
index a7a856c6e7e833bfaff5c88a6a55be42072c8418..5592d373758504af5f8d6b7b93aa66a6ded3c489 100644 (file)
@@ -21,6 +21,15 @@ define AT91BOOTSTRAP_EXTRACT_CMDS
        rmdir $(BUILD_DIR)/Bootstrap-v$(AT91BOOTSTRAP_VERSION)
 endef
 
+ifneq ($(call qstrip,$(BR2_TARGET_AT91BOOTSTRAP_CUSTOM_PATCH_DIR)),)
+define AT91BOOTSTRAP_APPLY_CUSTOM_PATCHES
+       support/scripts/apply-patches.sh $(@D) $(BR2_TARGET_AT91BOOTSTRAP_CUSTOM_PATCH_DIR) \
+               at91bootstrap-$(AT91BOOTSTRAP_VERSION)-\*.patch
+endef
+
+AT91BOOTSTRAP_POST_PATCH_HOOKS += AT91BOOTSTRAP_APPLY_CUSTOM_PATCHES
+endif
+
 define AT91BOOTSTRAP_BUILD_CMDS
        $(MAKE) CROSS_COMPILE=$(TARGET_CROSS) -C $(@D)/$(AT91BOOTSTRAP_MAKE_SUBDIR)
 endef