gcc: rename option for ARC gcc
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 Aug 2016 13:25:38 +0000 (15:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Sep 2016 19:19:24 +0000 (21:19 +0200)
The ARC gcc version is now based on gcc 6.x and no longer gcc 4.8.x,
which makes the option BR2_GCC_VERSION_4_8_ARC a bit irrelevant, as is
the prompt of this option.

This commit therefore renames this option to BR2_GCC_VERSION_ARC, and
adjust its prompt as well.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/gcc/Config.in.host
package/gcc/gcc-initial/gcc-initial.mk

index 8957be7cd7a51af628464e28f79fa32c1c6a4302..59147180c4ede377650cb9f030579d9e533813fe 100644 (file)
@@ -145,6 +145,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.11"
 
+config BR2_GCC_VERSION_4_8_ARC
+       bool "gcc arc option renamed"
+       select BR2_LEGACY
+       select BR2_GCC_VERSION_ARC
+       help
+         The option that selects the gcc version for the ARC
+         architecture has been renamed to BR2_GCC_VERSION_ARC.
+
 config BR2_KERNEL_HEADERS_4_0
        bool "kernel headers version 4.0.x are no longer supported"
        select BR2_KERNEL_HEADERS_3_18
index 134b16ce173d707c45807425cbe4e7cad24d4e0a..3460fdd3a11278e9604334b950647fc74691eed3 100644 (file)
@@ -8,7 +8,7 @@ config BR2_GCC_SUPPORTS_GRAPHITE
 
 choice
        prompt "GCC compiler Version"
-       default BR2_GCC_VERSION_4_8_ARC if BR2_arc
+       default BR2_GCC_VERSION_ARC if BR2_arc
        default BR2_GCC_VERSION_4_9_X
        help
          Select the version of gcc you wish to use.
@@ -56,12 +56,12 @@ choice
                select BR2_GCC_SUPPORTS_GRAPHITE
                select BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
 
-       config BR2_GCC_VERSION_4_8_ARC
-               bool "gcc 4.8-arc"
+       config BR2_GCC_VERSION_ARC
+               bool "gcc arc (6.x)"
                # Only supported architecture
                depends on BR2_arc
                select BR2_GCC_NEEDS_MPC
-               select BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+               select BR2_TOOLCHAIN_GCC_AT_LEAST_6
 
 
        config BR2_GCC_VERSION_4_9_X
@@ -121,7 +121,7 @@ config BR2_GCC_VERSION
        default "4.9.4"     if BR2_GCC_VERSION_4_9_X
        default "5.4.0"     if BR2_GCC_VERSION_5_X
        default "6.2.0"     if BR2_GCC_VERSION_6_X
-       default "arc-2016.09-eng013" if BR2_GCC_VERSION_4_8_ARC
+       default "arc-2016.09-eng013" if BR2_GCC_VERSION_ARC
 
 config BR2_EXTRA_GCC_CONFIG_OPTIONS
        string "Additional gcc options"
index 1e58d8b5f78978334c4cf27080aa89115907ad6e..aa88a6808f3996f8314eb28cf67e6152e0dbf19e 100644 (file)
@@ -29,7 +29,7 @@ HOST_GCC_INITIAL_PRE_CONFIGURE_HOOKS += HOST_GCC_CONFIGURE_SYMLINK
 # available (--with-newlib is passed, and therefore inhibit_libc is
 # defined), it tries to use the C library for the libgmon
 # library. Since it's not needed in gcc-initial, we disabled it here.
-ifeq ($(BR2_GCC_VERSION_4_8_ARC),y)
+ifeq ($(BR2_GCC_VERSION_ARC),y)
 define HOST_GCC_INITIAL_DISABLE_LIBGMON
        $(SED) 's/crtbeginS.o libgmon.a crtg.o/crtbeginS.o crtg.o/' \
                $(@D)/libgcc/config.host