- handle all gcc-4.x for the softfloat case.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 21 Jan 2007 11:50:10 +0000 (11:50 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 21 Jan 2007 11:50:10 +0000 (11:50 -0000)
toolchain/gcc/Makefile.in

index 1dcfcba1294daef63dc7a8bd8a355fc99f7cf973..41e23cf591ec825cf1eb8dd3b74793676c14e14c 100644 (file)
@@ -22,6 +22,7 @@ endif
 ifeq ($(strip $(BR2_GCC_USE_SJLJ_EXCEPTIONS)),y)
 GCC_USE_SJLJ_EXCEPTIONS:=--enable-sjlj-exceptions
 endif
+
 ifeq ($(BR2_SOFT_FLOAT),y)
 # gcc 3.4.x soft float configuration is different than previous versions.
 ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
@@ -30,10 +31,7 @@ else
 SOFT_FLOAT_CONFIG_OPTION:=--without-float
 endif
 # again... there must be a better way
-ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
-SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
-endif
-ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+ifeq ($(findstring 4.,$(GCC_VERSION)),4.)
 SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
 endif
 TARGET_SOFT_FLOAT:=-msoft-float