package/clamav: link with libatomic when needed
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 16 Feb 2019 08:19:05 +0000 (09:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 24 Feb 2019 20:37:28 +0000 (21:37 +0100)
Configure check for OpenSSL fails:

/accts/mlweber1/rclinux/rc-buildroot-test/scripts/instance-3/output/host/sparc-buildroot-linux-uclibc/sysroot/usr/lib/libcrypto.a(threads_pthread.o): In function `CRYPTO_atomic_add':
threads_pthread.c:(.text+0x1dc): undefined reference to `__atomic_is_lock_free'
threads_pthread.c:(.text+0x1f4): undefined reference to `__atomic_fetch_add_4'

Fixes
http://autobuild.buildroot.net/results/cae8da81adff3ba493154e0ba8b21d90367f82eb/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/clamav/clamav.mk

index b5a184a67ce1a7e9dd4e92430280b9f939357a1b..8900b4819a6e228659250a875393367e6250d009 100644 (file)
@@ -22,6 +22,10 @@ CLAMAV_CONF_ENV = \
        ac_cv_c_mmap_private=yes \
        have_cv_ipv6=yes
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+CLAMAV_CONF_ENV += LIBS=-latomic
+endif
+
 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
 CLAMAV_CONF_OPTS = \
        --with-dbdir=/var/lib/clamav \