package: add classpath
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 4 Dec 2012 17:59:09 +0000 (09:59 -0800)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 4 Dec 2012 18:21:05 +0000 (10:21 -0800)
Requires java, javac and jar on the build machine, similar to how we
require gcc/g++.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
classpath: fixup

package/Config.in
package/classpath/Config.in [new file with mode: 0644]
package/classpath/classpath.mk [new file with mode: 0644]

index 5ba1f0536823838cf203341d9e2a5bbbfd897e38..66e8352505d6a7e447ad5430e493891cac29aef3 100644 (file)
@@ -489,6 +489,7 @@ endmenu
 menu "Other"
 source "package/apr/Config.in"
 source "package/apr-util/Config.in"
+source "package/classpath/Config.in"
 source "package/fftw/Config.in"
 source "package/libargtable2/Config.in"
 source "package/argp-standalone/Config.in"
diff --git a/package/classpath/Config.in b/package/classpath/Config.in
new file mode 100644 (file)
index 0000000..45d5984
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_CLASSPATH
+       bool "classpath"
+       depends on BR2_PACKAGE_JAMVM
+       depends on BR2_INET_IPV6
+       help
+         GNU Classpath, Essential Libraries for Java, is a GNU
+         project to create free core class libraries for use with
+         virtual machines and compilers for the java programming
+         language.
+
+         http://classpath.org
+
+comment "classpath requires a toolchain with IPV6 support"
+       depends on !BR2_INET_IPV6
diff --git a/package/classpath/classpath.mk b/package/classpath/classpath.mk
new file mode 100644 (file)
index 0000000..9142f69
--- /dev/null
@@ -0,0 +1,55 @@
+CLASSPATH_VERSION = 0.98
+CLASSPATH_SITE = $(BR2_GNU_MIRROR)/classpath
+CLASSPATH_CONF_OPT = \
+       --disable-examples \
+       --disable-plugin \
+       --disable-rpath \
+       --disable-Werror \
+       --disable-gconf-peer \
+       --disable-tools
+
+CLASSPATH_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+CLASSPATH_CONF_OPT += --enable-alsa
+CLASSPATH_DEPENDENCIES += alsa-lib
+else
+CLASSPATH_CONF_OPT += --disable-alsa
+endif
+
+ifeq ($(BR2_PACKAGE_GMP),y)
+CLASSPATH_CONF_OPT += --enable-gmp
+CLASSPATH_DEPENDENCIES += gmp
+else
+CLASSPATH_CONF_OPT += --disable-gmp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
+CLASSPATH_CONF_OPT += --enable-gstreamer-peer
+CLASSPATH_DEPENDENCIES += gst-plugins-base
+else
+CLASSPATH_CONF_OPT += --disable-gstreamer-peer
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG7),yy)
+CLASSPATH_CONF_OPT += --enable-gtk-peer
+CLASSPATH_DEPENDENCIES += libgtk2
+else
+CLASSPATH_CONF_OPT += --disable-gtk-peer
+endif
+
+ifeq ($(BR2_PACKAGE_QT),y)
+CLASSPATH_CONF_OPT += --enable-qt-peer
+CLASSPATH_DEPENDENCIES += qt
+else
+CLASSPATH_CONF_OPT += --disable-qt-peer
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXML2)$(BR2_PACKAGE_LIBXSLT),yy)
+CLASSPATH_CONF_OPT += --enable-xmlj
+CLASSPATH_DEPENDENCIES += libxml2 libxslt
+else
+CLASSPATH_CONF_OPT += --disable-xmlj
+endif
+
+$(eval $(autotools-package))