package/jitterentropy-library: ensure make command is continued across new line
authorMarkus Mayer <mmayer@broadcom.com>
Fri, 25 Oct 2019 23:23:02 +0000 (16:23 -0700)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 26 Oct 2019 05:29:02 +0000 (07:29 +0200)
The first line of JITTERENTROPY_LIBRARY_BUILD_CMDS must end with "\" to
concatenate the two lines.

Fixes: build error
[...]
/usr/bin/make -j33 -C
/local/users/mmayer/buildroot/output/arm64/build/jitterentropy-library-2.2.0
/local/users/mmayer/buildroot/output/arm64/host/bin/aarch64-linux-gcc
-shared -Wl,-soname,libjitterentropy.so.2 -o libjitterentropy.so.2.2.0
jitterentropy-base.o  -Wl,-z,relro,-z,now  -lrt
/local/users/mmayer/buildroot/output/arm64/host/bin/aarch64-linux-ar
rcs libjitterentropy.a jitterentropy-base.o
jitterentropy
/bin/bash: jitterentropy: command not found

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jitterentropy-library/jitterentropy-library.mk

index 75c770f53892c9ccd0d9bf9b8f4b6748cffeae0e..3db04b27d3855caab15cd1f5db504e83992d871b 100644 (file)
@@ -22,7 +22,7 @@ JITTERENTROPY_LIBRARY_INSTALL_TARGETS += install-shared
 endif
 
 define JITTERENTROPY_LIBRARY_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
                $(JITTERENTROPY_LIBRARY_BUILD_TARGETS)
 endef