New package: feh
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 17 Oct 2011 08:41:07 +0000 (10:41 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 10 Dec 2011 21:13:21 +0000 (22:13 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Tested-By: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/feh/Config.in [new file with mode: 0644]
package/feh/feh.mk [new file with mode: 0644]

index cf0f400413b4f282716976eecd93085409ae4c39..eb93b1c45b6660f8a2c7670fd5f223cd983c6bf3 100644 (file)
@@ -133,6 +133,7 @@ source "package/fluxbox/Config.in"
 comment "X applications"
 source "package/alsamixergui/Config.in"
 source "package/docker/Config.in"
+source "package/feh/Config.in"
 source "package/gqview/Config.in"
 source "package/gmpc/Config.in"
 source "package/gob2/Config.in"
diff --git a/package/feh/Config.in b/package/feh/Config.in
new file mode 100644 (file)
index 0000000..31e7239
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_FEH
+       bool "feh"
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXINERAMA
+       select BR2_PACKAGE_XLIB_LIBXT
+       select BR2_PACKAGE_IMLIB2_PNG
+       select BR2_PACKAGE_IMLIB2_JPEG
+       select BR2_PACKAGE_IMLIB2_X
+       select BR2_PACKAGE_GIBLIB
+       select BR2_PACKAGE_LIBCURL
+       help
+         feh is an X11 image viewer aimed mostly at console users.
+
+         http://feh.finalrewind.org/
diff --git a/package/feh/feh.mk b/package/feh/feh.mk
new file mode 100644 (file)
index 0000000..eb68277
--- /dev/null
@@ -0,0 +1,21 @@
+FEH_VERSION = 2.0
+FEH_SOURCE = feh-$(FEH_VERSION).tar.bz2
+FEH_SITE = http://feh.finalrewind.org/
+FEH_DEPENDENCIES = libcurl giblib imlib2 libpng xlib_libXinerama xlib_libXt
+
+define FEH_BUILD_CMDS
+       $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+               -C $(@D) all
+endef
+
+define FEH_INSTALL_TARGET_CMDS
+       $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) " \
+               DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+define FEH_UNINSTALL_TARGET_CMDS
+       $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) " \
+               DESTDIR=$(TARGET_DIR) -C $(@D) uninstall
+endef
+
+$(eval $(call GENTARGETS))