package/x11r7/xdriver_xf86-video-fbturbo: needs dri2 for libump
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 28 May 2016 17:17:19 +0000 (19:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 31 May 2016 20:43:08 +0000 (22:43 +0200)
xdriver_xf86-video-fbturbo has an optional dependency to libump
currently not handled by buildroot:
https://github.com/ssvb/xf86-video-fbturbo/blob/master/configure.ac#L91

If libump was compiled incidentally before xdriver_xf86-video-fbturbo
sunxi_mali_ump_dri2.c is compiled which depends on dri2:
https://github.com/ssvb/xf86-video-fbturbo/blob/master/src/Makefile.am#L59

This patch adds a dependency for dri2proto to enable dri2 support in
X.org and adds libump as dependency for a reproducable build to fix
http://autobuild.buildroot.net/results/656/656520682a5ac6fe5e1e741e1a92b1eab4245f2d/

[Peter: also add dri2proto to _DEPENDENCIES]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/x11r7/xdriver_xf86-video-fbturbo/Config.in
package/x11r7/xdriver_xf86-video-fbturbo/xdriver_xf86-video-fbturbo.mk

index 8fec5c2834cca0b68966927d7edd5fe69a1c924c..7825901e9838b06b80bd74ba01767d2519fa636e 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_XDRIVER_XF86_VIDEO_FBTURBO
        bool "xf86-video-fbturbo"
        select BR2_PACKAGE_LIBDRM
        select BR2_PACKAGE_PIXMAN
+       select BR2_PACKAGE_XPROTO_DRI2PROTO if BR2_PACKAGE_LIBUMP
        select BR2_PACKAGE_XPROTO_FONTSPROTO
        select BR2_PACKAGE_XPROTO_RANDRPROTO
        select BR2_PACKAGE_XPROTO_RENDERPROTO
index b2053d3e59040d6b2cf75ed64cad2ed4d1a7312b..15f4cd10937a53c9af4f922a742ff67c92002846 100644 (file)
@@ -26,6 +26,14 @@ else
 XDRIVER_XF86_VIDEO_FBTURBO_CONF_OPTS += --disable-pciaccess
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUMP),y)
+XDRIVER_XF86_VIDEO_FBTURBO_DEPENDENCIES += libump
+endif
+
+ifeq ($(BR2_PACKAGE_XPROTO_DRI2PROTO),y)
+XDRIVER_XF86_VIDEO_FBTURBO_DEPENDENCIES += xproto_dri2proto
+endif
+
 define XDRIVER_XF86_VIDEO_FBTURBO_INSTALL_CONF_FILE
        $(INSTALL) -m 0644 -D $(@D)/xorg.conf $(TARGET_DIR)/etc/X11/xorg.conf
 endef