collectd: use --disable-werror
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 24 Jun 2018 15:44:52 +0000 (17:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 24 Jun 2018 19:10:06 +0000 (21:10 +0200)
Since version 5.6.0, --disable-werror is available:
https://github.com/collectd/collectd/pull/1222

So use this option, instead of adding a hook to remove it from
Makefile.in

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/collectd.mk

index ef45f342aeb46172be27ae34761afd9dff7b648b..589324e612ae2482882caaf7ea1f492fa827e0d2 100644 (file)
@@ -42,6 +42,7 @@ COLLECTD_CONF_OPTS += \
        --with-nan-emulation \
        --with-fp-layout=$(COLLECTD_FP_LAYOUT) \
        --with-perl-bindings=no \
+       --disable-werror \
        $(foreach p, $(COLLECTD_PLUGINS_DISABLE), --disable-$(p)) \
        $(if $(BR2_PACKAGE_COLLECTD_AGGREGATION),--enable-aggregation,--disable-aggregation) \
        $(if $(BR2_PACKAGE_COLLECTD_APACHE),--enable-apache,--disable-apache) \
@@ -194,14 +195,6 @@ else
 COLLECTD_CONF_OPTS += --with-libgcrypt=no
 endif
 
-# released software should not break on minor warnings
-define COLLECTD_DROP_WERROR
-       $(SED) 's/-Werror//' \
-               $(@D)/src/Makefile.in $(@D)/src/libcollectdclient/Makefile.in
-endef
-
-COLLECTD_POST_PATCH_HOOKS += COLLECTD_DROP_WERROR
-
 define COLLECTD_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
        rm -f $(TARGET_DIR)/usr/bin/collectd-nagios