package/micropython: fix build with gcc 4.8
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 19 Sep 2020 10:01:38 +0000 (12:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 19 Sep 2020 12:13:50 +0000 (14:13 +0200)
micropython uses -Wfloat-conversion since version 1.13 and
https://github.com/micropython/micropython/commit/30840ebc9925bb8ef025dbc2d5982b1bfeb75f1b

This will result in the following build failure with gcc 4.8:
arm-none-linux-gnueabi-gcc: error: unrecognized command line option '-Wfloat-conversion'

To avoid this build failure, set CWARN to an empty value moreover, while
at it, move some duplicated variables under MICROPYTHON_MAKE_OPTS

Fixes:
 - http://autobuild.buildroot.org/results/6fe5a5ab91a5d235147e74461bb165ec2cfdc967

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/micropython/micropython.mk

index 7c83b18b4ed516dca75111a08f88a32380f0a5ab..a126b3eeae874e5a76ab17f0d8840ff0bfa515dd 100644 (file)
@@ -23,22 +23,22 @@ endif
 
 # When building from a tarball we don't have some of the dependencies that are in
 # the git repository as submodules
-MICROPYTHON_MAKE_OPTS = MICROPY_PY_BTREE=0
-MICROPYTHON_MAKE_OPTS += MICROPY_PY_USSL=0
+MICROPYTHON_MAKE_OPTS += \
+       MICROPY_PY_BTREE=0 \
+       MICROPY_PY_USSL=0 \
+       CROSS_COMPILE=$(TARGET_CROSS) \
+       CFLAGS_EXTRA=$(MICROPYTHON_CFLAGS) \
+       CWARN=
 
 define MICROPYTHON_BUILD_CMDS
        $(MICROPYTHON_MAKE_ENV) $(MAKE) -C $(@D)/mpy-cross
        $(MICROPYTHON_MAKE_ENV) $(MAKE) -C $(@D)/ports/unix \
-               $(MICROPYTHON_MAKE_OPTS) \
-               CROSS_COMPILE=$(TARGET_CROSS) \
-               CFLAGS_EXTRA=$(MICROPYTHON_CFLAGS)
+               $(MICROPYTHON_MAKE_OPTS)
 endef
 
 define MICROPYTHON_INSTALL_TARGET_CMDS
        $(MICROPYTHON_MAKE_ENV) $(MAKE) -C $(@D)/ports/unix \
                $(MICROPYTHON_MAKE_OPTS) \
-               CROSS_COMPILE=$(TARGET_CROSS) \
-               CFLAGS_EXTRA=$(MICROPYTHON_CFLAGS) \
                DESTDIR=$(TARGET_DIR) \
                PREFIX=/usr \
                install