Add configuration possibility for host Gnome Lib installation
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sat, 5 Jul 2008 09:22:38 +0000 (09:22 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sat, 5 Jul 2008 09:22:38 +0000 (09:22 -0000)
Config.in
Makefile

index 60aefc92c6c54af07a7440db2faec0ed15c81f78..129171bbf995a809c49ddb3c29f510cc134974ca 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -78,6 +78,17 @@ config BR2_DL_DIR
 
          The default is $(BASE_DIR)/dl
 
+config BR2_HOST_GLIB
+       string "Location of host Gnome library"
+       default "/usr"
+       help
+         Directory where Gnome is installed on the host
+         Gnome applications is installed in $(BR2_HOST_LIB)/bin 
+         This is needed to build libgtk etc.
+         The default is /usr
+         It can be overridden by the BUILDROOT_HOST_GLIB
+         shell variable
+
 source "target/device/Config.in.mirrors"
 
 config BR2_STAGING_DIR
index f57d1f39679bbae939abac6ffd13f347ec2f9211..8255771cacf35fe14896bf79448582dab6f8a9c1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ noconfig_targets:=menuconfig config oldconfig randconfig \
 ifneq ($(BUILDROOT_LOCAL),)
 BR2_LOCAL:=$(BUILDROOT_LOCAL)
 else
-BR2_LOCAL:=$(TOPDIR)/local
+BR2_LOCAL:=$(TOPDIR)local
 endif
 
 # $(shell find . -name *_defconfig |sed 's/.*\///')
@@ -57,6 +57,12 @@ BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
 endif
 LOCAL:=$(BR2_LOCAL)
 
+ifneq ($(BUILDROOT_HOST_GLIB),)
+HOST_GLIB:=$(BUILDROOT_HOST_GLIB)
+else
+HOST_GLIB:=$(BR2_HOST_GLIB)
+endif
+
 # To put more focus on warnings, be less verbose as default
 # Use 'make V=1' to see the full commands
 ifdef V
@@ -511,4 +517,8 @@ help:
 
 .PHONY: dummy subdirs release distclean clean config oldconfig \
        menuconfig tags check test depend defconfig help
-       
+
+status:
+       @echo LOCAL=$(LOCAL)
+       @echo BR2_DL_DIR=$(BR2_DL_DIR)
+       @echo HOST_GLIB=$(HOST_GLIB)