lsof: fix build after gentargets conversion
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 27 Dec 2010 14:49:00 +0000 (15:49 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 27 Dec 2010 14:49:00 +0000 (15:49 +0100)
With the gentargets conversion, the tarball is extracted directly in the
source directory, so adjust paths to match.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lsof/lsof.mk

index 05365dae3801adbf3e27e499766a48f22a7ee6fe..167cb2041185ca0164a5b82fef29d2b5adc7fdc5 100644 (file)
@@ -18,16 +18,16 @@ endif
 ifeq ($(BR2_USE_WCHAR),)
 define LSOF_CONFIGURE_WCHAR_FIXUPS
        $(SED) 's,^#define[[:space:]]*HASWIDECHAR.*,#undef HASWIDECHAR,' \
-               $(@D)/lsof_$(LSOF_VERSION)_src/machine.h
+               $(@D)/machine.h
        $(SED) 's,^#define[[:space:]]*WIDECHARINCL.*,,' \
-               $(@D)/lsof_$(LSOF_VERSION)_src/machine.h
+               $(@D)/machine.h
 endef
 endif
 
 ifeq ($(BR2_ENABLE_LOCALE),)
 define LSOF_CONFIGURE_LOCALE_FIXUPS
        $(SED) 's,^#define[[:space:]]*HASSETLOCALE.*,#undef HASSETLOCALE,' \
-               $(@D)/lsof_$(LSOF_VERSION)_src/machine.h
+               $(@D)/machine.h
 endef
 endif
 
@@ -60,7 +60,7 @@ define LSOF_UNINSTALL_TARGET_CMDS
 endef
 
 define LSOF_CLEAN_CMDS
-       -$(MAKE) -C $(@D)/lsof_$(LSOF_VERSION)_src clean
+       -$(MAKE) -C $(@D) clean
 endef
 
 $(eval $(call GENTARGETS,package,lsof))