package/gnuradio: add optional log4cpp dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 8 Mar 2019 21:39:56 +0000 (22:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 9 Mar 2019 14:07:09 +0000 (15:07 +0100)
Currently, logger component is enabled if log4cpp is found

Moreover, it should be noted that log4cpp is now mandatory in latest
upstream:
https://github.com/gnuradio/gnuradio/commit/d2428961205bf62e6b39966f040f98435e5cc2ed

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gnuradio/Config.in
package/gnuradio/gnuradio.mk

index 3fdaea850e5d3d6b8a8795318496695c3d5e3283..6d0669779f0bf3fab2d8c0461ea8556e9d36c7b5 100644 (file)
@@ -56,6 +56,12 @@ config BR2_PACKAGE_GNURADIO_FEC
        help
          FEC signal processing blocks
 
+config BR2_PACKAGE_GNURADIO_LOG
+       bool "gr-log support"
+       select BR2_PACKAGE_LOG4CPP
+       help
+         Enable logger component
+
 config BR2_PACKAGE_GNURADIO_PYTHON
        bool "python support"
        depends on BR2_PACKAGE_PYTHON
index 202c2213a718984de07011c526c05dbf02f49f19..ef9723cb01314f4cccebe7f69eeda9cc7ab0c9f4 100644 (file)
@@ -115,6 +115,13 @@ else
 GNURADIO_CONF_OPTS += -DENABLE_GR_FILTER=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_GNURADIO_LOG),y)
+GNURADIO_DEPENDENCIES += log4cpp
+GNURADIO_CONF_OPTS += -DENABLE_GR_LOG=ON
+else
+GNURADIO_CONF_OPTS += -DENABLE_GR_LOG=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_GNURADIO_PYTHON),y)
 GNURADIO_DEPENDENCIES += python
 GNURADIO_CONF_OPTS += -DENABLE_PYTHON=ON