squid: bump to version 3.4.3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 4 Feb 2014 09:38:25 +0000 (06:38 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2014 09:44:28 +0000 (10:44 +0100)
And exclude for avr32 since the toolchain is too old, fixes:
http://autobuild.buildroot.net/results/c6a/c6a686885a6c845b527c58c3f2075f82bcf120e2/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/squid/Config.in
package/squid/squid-02-atomic-cross.patch [deleted file]
package/squid/squid-02-missing-include-time_h.patch [new file with mode: 0644]
package/squid/squid-03-missing-include-time_h.patch [deleted file]
package/squid/squid.mk

index 33776ca5dec5b22e4fd882f57b18a919e5adfeb4..ad9fab5931326fadc370a5654660a3a8635d4547 100644 (file)
@@ -1,5 +1,6 @@
 comment "squid needs a toolchain w/ C++, IPv6"
        depends on BR2_USE_MMU
+       depends on !BR2_avr32 # toolchain too old
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_INET_IPV6
 
 config BR2_PACKAGE_SQUID
diff --git a/package/squid/squid-02-atomic-cross.patch b/package/squid/squid-02-atomic-cross.patch
deleted file mode 100644 (file)
index c1b59dc..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-AC_RUN_IFELSE is bad for cross compiling, switch to AC_COMPILE_IFELSE
-since it's enough for this test.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura squid-3.3.9.orig/configure.ac squid-3.3.9/configure.ac
---- squid-3.3.9.orig/configure.ac      2013-09-13 09:15:32.473365627 -0300
-+++ squid-3.3.9/configure.ac   2013-09-13 13:27:06.829711487 -0300
-@@ -392,7 +392,7 @@
- dnl Check for atomic operations support in the compiler
- dnl
- AC_MSG_CHECKING([for GNU atomic operations support])
--AC_RUN_IFELSE([AC_LANG_PROGRAM([[
-+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-     int n = 0;
- ]],[[
-     __sync_add_and_fetch(&n, 10); // n becomes 10
diff --git a/package/squid/squid-02-missing-include-time_h.patch b/package/squid/squid-02-missing-include-time_h.patch
new file mode 100644 (file)
index 0000000..18b3ab3
--- /dev/null
@@ -0,0 +1,28 @@
+ipc/Kid.cc: add missing include of time.h
+
+Function time() comes from <time.h>, so add the necessary include.
+This fixes compilation on some configurations, for example
+http://autobuild.buildroot.net/results/b33/b33e1f41e50b6e7ac3e30806b9a617d451bc27b4/
+
+Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
+Upstream-status: submitted (http://bugs.squid-cache.org/show_bug.cgi?id=3967)
+
+---
+ src/ipc/Kid.cc |  4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+
+diff --git a/src/ipc/Kid.cc b/src/ipc/Kid.cc
+--- a/src/ipc/Kid.cc
++++ b/src/ipc/Kid.cc
+@@ -11,6 +11,10 @@
+ #include <sys/wait.h>
+ #endif
++#if HAVE_TIME_H
++#include <time.h>
++#endif
++
+ int TheProcessKind = pkOther;
+ Kid::Kid():
diff --git a/package/squid/squid-03-missing-include-time_h.patch b/package/squid/squid-03-missing-include-time_h.patch
deleted file mode 100644 (file)
index 18b3ab3..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-ipc/Kid.cc: add missing include of time.h
-
-Function time() comes from <time.h>, so add the necessary include.
-This fixes compilation on some configurations, for example
-http://autobuild.buildroot.net/results/b33/b33e1f41e50b6e7ac3e30806b9a617d451bc27b4/
-
-Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
-Upstream-status: submitted (http://bugs.squid-cache.org/show_bug.cgi?id=3967)
-
----
- src/ipc/Kid.cc |  4 ++++
- 1 files changed, 4 insertions(+), 0 deletions(-)
-
-
-diff --git a/src/ipc/Kid.cc b/src/ipc/Kid.cc
---- a/src/ipc/Kid.cc
-+++ b/src/ipc/Kid.cc
-@@ -11,6 +11,10 @@
- #include <sys/wait.h>
- #endif
-+#if HAVE_TIME_H
-+#include <time.h>
-+#endif
-+
- int TheProcessKind = pkOther;
- Kid::Kid():
index 7f1f0f50c3d6eb9e7f8da77c3f2d42755228dde8..529c5df14898a0b426881456439c90a78aa236b9 100644 (file)
@@ -5,11 +5,12 @@
 ################################################################################
 
 SQUID_VERSION_MAJOR = 3.4
-SQUID_VERSION = $(SQUID_VERSION_MAJOR).2
+SQUID_VERSION = $(SQUID_VERSION_MAJOR).3
 SQUID_SOURCE = squid-$(SQUID_VERSION).tar.xz
 SQUID_SITE = http://www.squid-cache.org/Versions/v3/$(SQUID_VERSION_MAJOR)
 SQUID_LICENSE = GPLv2+
 SQUID_LICENSE_FILES = COPYING
+# For squid-01-assume-get-certificate-ok.patch
 SQUID_AUTORECONF = YES
 SQUID_DEPENDENCIES = libcap host-libcap host-pkgconf \
        $(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)