exim: get rid of the convert the custom config file boolean knob
authorLuca Ceresoli <luca@lucaceresoli.net>
Wed, 16 Jul 2014 16:11:55 +0000 (18:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Jul 2014 17:47:56 +0000 (19:47 +0200)
The current implementation causes troubles with the autobuilders when they
set BR2_PACKAGE_EXIM_CUSTOM_CONFIG=y, because in these cases
BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE is empty, and this is a configuration
error.

Solve the problem by entirely reomving the BR2_PACKAGE_EXIM_CUSTOM_CONFIG
boolean knob. Activation of the custon configuration file is now detected by
the fact that BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE is non-empty.

Fixes:
  http://autobuild.buildroot.org/results/0db/0db54c555f6c7e635ebf99f86b3f91dc31e441f0/

[Thomas: slightly improve commit log.]

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: bernd.kuhls@t-online.de
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/exim/Config.in
package/exim/exim.mk

index af54acbbf2efd2707eac5c75a0742fbc81bf6ce0..bd4ef1fa8406206892339682545ac3aa8420b2e5 100644 (file)
@@ -11,20 +11,16 @@ config BR2_PACKAGE_EXIM
 
 if BR2_PACKAGE_EXIM
 
-config BR2_PACKAGE_EXIM_CUSTOM_CONFIG
-       bool "Use a custom configuration file"
-       help
-         By default Buildroot generates configuration file for exim with
-         reasonable settings.
-         Enable this option if you want to override the configuration file
-         generated by Buildroot with a customized file. Then set the path
-         to your configuration file in BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE.
-
 config BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE
        string "Custom configuration file"
-       depends on BR2_PACKAGE_EXIM_CUSTOM_CONFIG
        help
-         Specify a file to use as the exim configuration file.
+         By default, when this option is left empty, Buildroot
+         generates a configuration file for exim with reasonable
+         settings.
+
+         If you want to override the configuration file generated by
+         Buildroot with a customized file, set here the path to your
+         configuration file with this option.
 
          This file shall comply with the syntax defined in the exim
          documentation (http://www.exim.org/docs.html).
index 2e51a0d9b96e75f54d386c4770c06a44d384a18b..8be8e75cf33a241329b44534d871b02dc8ac25d2 100644 (file)
@@ -57,10 +57,7 @@ define EXIM_CONFIGURE_TOOLCHAIN
        $(call exim-config-add,HOSTCFLAGS,$(HOSTCFLAGS))
 endef
 
-ifeq ($(BR2_PACKAGE_EXIM_CUSTOM_CONFIG),y)
-ifeq ($(call qstrip,$(BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE)),)
-$(error No exim configuration file specified, check your BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE setting)
-endif
+ifneq ($(call qstrip,$(BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE)),)
 define EXIM_CONFIGURE_CMDS
        $(EXIM_USE_CUSTOM_CONFIG_FILE)
        $(EXIM_CONFIGURE_TOOLCHAIN)