Upped version, lm-sensors.01.susv3-legacy.patch seems to not be needed
authorThomas Lundquist <lists@zelow.no>
Fri, 25 Jan 2008 09:46:21 +0000 (09:46 -0000)
committerThomas Lundquist <lists@zelow.no>
Fri, 25 Jan 2008 09:46:21 +0000 (09:46 -0000)
any more but keeping it for now. Hopefully closing bug #1939

package/lm-sensors/lm-sensors.01.susv3-legacy.patch [deleted file]
package/lm-sensors/lm-sensors.01.susv3-legacy.patch.not [new file with mode: 0644]
package/lm-sensors/lm-sensors.mk

diff --git a/package/lm-sensors/lm-sensors.01.susv3-legacy.patch b/package/lm-sensors/lm-sensors.01.susv3-legacy.patch
deleted file mode 100644 (file)
index 85d84b7..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-diff -rdup lm_sensors-2.10.4.oorig/lib/proc.c lm_sensors-2.10.4/lib/proc.c
---- lm_sensors-2.10.4.oorig/lib/proc.c 2007-07-17 06:53:06.000000000 +0200
-+++ lm_sensors-2.10.4/lib/proc.c       2007-09-20 13:30:39.000000000 +0200
-@@ -93,16 +93,16 @@ int sensors_read_proc_bus(void)
-   while (fgets(line,255,f)) {
-     if (strlen(line) > 0)
-       line[strlen(line)-1] = '\0';
--    if (! (border = rindex(line,'\t')))
-+    if (! (border = strrchr(line,'\t')))
-       goto ERROR;
-     /* Skip algorithm name */
-     *border='\0';
--    if (! (border = rindex(line,'\t')))
-+    if (! (border = strrchr(line,'\t')))
-       goto ERROR;
-     if (! (entry.adapter = strdup(border + 1)))
-       goto FAT_ERROR;
-     *border='\0';
--    if (! (border = rindex(line,'\t')))
-+    if (! (border = strrchr(line,'\t')))
-       goto ERROR;
-     *border='\0';
-     if (strncmp(line,"i2c-",4))
-@@ -155,8 +155,8 @@ int sensors_read_proc(sensors_chip_name 
-               strcpy(n, name.busname);
-               strcat(n, "/");
-               strcpy(altn, n);
--              /* use rindex to append sysname to n */
--              getsysname(the_feature, rindex(n, '\0'), &mag, rindex(altn, '\0'));
-+              /* use strrchr to append sysname to n */
-+              getsysname(the_feature, strrchr(n, '\0'), &mag, strrchr(altn, '\0'));
-               if ((f = fopen(n, "r")) != NULL
-                || (f = fopen(altn, "r")) != NULL) {
-                       int res = fscanf(f, "%lf", value);
-@@ -198,8 +198,8 @@ int sensors_write_proc(sensors_chip_name
-               strcpy(n, name.busname);
-               strcat(n, "/");
-               strcpy(altn, n);
--              /* use rindex to append sysname to n */
--              getsysname(the_feature, rindex(n, '\0'), &mag, rindex(altn, '\0'));
-+              /* use strrchr to append sysname to n */
-+              getsysname(the_feature, strrchr(n, '\0'), &mag, strrchr(altn, '\0'));
-               if ((f = fopen(n, "w")) != NULL
-                || (f = fopen(altn, "w")) != NULL) {
-                       for (; mag > 0; mag --)
-diff -rdup lm_sensors-2.10.4.oorig/prog/dump/i2cbusses.c lm_sensors-2.10.4/prog/dump/i2cbusses.c
---- lm_sensors-2.10.4.oorig/prog/dump/i2cbusses.c      2007-07-17 06:53:10.000000000 +0200
-+++ lm_sensors-2.10.4/prog/dump/i2cbusses.c    2007-09-20 13:29:19.000000000 +0200
-@@ -185,7 +185,7 @@ found:
-                               fprintf(stderr, "%s: read error\n", n);
-                               continue;
-                       }
--                      if((border = index(x, '\n')) != NULL)
-+                      if((border = strchr(x, '\n')) != NULL)
-                               *border = 0;
-                       if(count++ == 0 && !procfmt)
-                               fprintf(stderr,"  Installed I2C busses:\n");
diff --git a/package/lm-sensors/lm-sensors.01.susv3-legacy.patch.not b/package/lm-sensors/lm-sensors.01.susv3-legacy.patch.not
new file mode 100644 (file)
index 0000000..85d84b7
--- /dev/null
@@ -0,0 +1,57 @@
+diff -rdup lm_sensors-2.10.4.oorig/lib/proc.c lm_sensors-2.10.4/lib/proc.c
+--- lm_sensors-2.10.4.oorig/lib/proc.c 2007-07-17 06:53:06.000000000 +0200
++++ lm_sensors-2.10.4/lib/proc.c       2007-09-20 13:30:39.000000000 +0200
+@@ -93,16 +93,16 @@ int sensors_read_proc_bus(void)
+   while (fgets(line,255,f)) {
+     if (strlen(line) > 0)
+       line[strlen(line)-1] = '\0';
+-    if (! (border = rindex(line,'\t')))
++    if (! (border = strrchr(line,'\t')))
+       goto ERROR;
+     /* Skip algorithm name */
+     *border='\0';
+-    if (! (border = rindex(line,'\t')))
++    if (! (border = strrchr(line,'\t')))
+       goto ERROR;
+     if (! (entry.adapter = strdup(border + 1)))
+       goto FAT_ERROR;
+     *border='\0';
+-    if (! (border = rindex(line,'\t')))
++    if (! (border = strrchr(line,'\t')))
+       goto ERROR;
+     *border='\0';
+     if (strncmp(line,"i2c-",4))
+@@ -155,8 +155,8 @@ int sensors_read_proc(sensors_chip_name 
+               strcpy(n, name.busname);
+               strcat(n, "/");
+               strcpy(altn, n);
+-              /* use rindex to append sysname to n */
+-              getsysname(the_feature, rindex(n, '\0'), &mag, rindex(altn, '\0'));
++              /* use strrchr to append sysname to n */
++              getsysname(the_feature, strrchr(n, '\0'), &mag, strrchr(altn, '\0'));
+               if ((f = fopen(n, "r")) != NULL
+                || (f = fopen(altn, "r")) != NULL) {
+                       int res = fscanf(f, "%lf", value);
+@@ -198,8 +198,8 @@ int sensors_write_proc(sensors_chip_name
+               strcpy(n, name.busname);
+               strcat(n, "/");
+               strcpy(altn, n);
+-              /* use rindex to append sysname to n */
+-              getsysname(the_feature, rindex(n, '\0'), &mag, rindex(altn, '\0'));
++              /* use strrchr to append sysname to n */
++              getsysname(the_feature, strrchr(n, '\0'), &mag, strrchr(altn, '\0'));
+               if ((f = fopen(n, "w")) != NULL
+                || (f = fopen(altn, "w")) != NULL) {
+                       for (; mag > 0; mag --)
+diff -rdup lm_sensors-2.10.4.oorig/prog/dump/i2cbusses.c lm_sensors-2.10.4/prog/dump/i2cbusses.c
+--- lm_sensors-2.10.4.oorig/prog/dump/i2cbusses.c      2007-07-17 06:53:10.000000000 +0200
++++ lm_sensors-2.10.4/prog/dump/i2cbusses.c    2007-09-20 13:29:19.000000000 +0200
+@@ -185,7 +185,7 @@ found:
+                               fprintf(stderr, "%s: read error\n", n);
+                               continue;
+                       }
+-                      if((border = index(x, '\n')) != NULL)
++                      if((border = strchr(x, '\n')) != NULL)
+                               *border = 0;
+                       if(count++ == 0 && !procfmt)
+                               fprintf(stderr,"  Installed I2C busses:\n");
index 60c5307cab2ae784907fe75687701679831e77bf..d218ebd11c66107115d3c30abd0f9c185a3c329f 100644 (file)
@@ -3,9 +3,9 @@
 # lm-sensors
 #
 #############################################################
-LM_SENSORS_VERSION:=2.10.4
+LM_SENSORS_VERSION:=2.10.5
 LM_SENSORS_SOURCE:=lm-sensors_$(LM_SENSORS_VERSION).orig.tar.gz
-LM_SENSORS_PATCH:=lm-sensors_$(LM_SENSORS_VERSION)-3.diff.gz
+LM_SENSORS_PATCH:=lm-sensors_$(LM_SENSORS_VERSION)-5.diff.gz
 LM_SENSORS_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/l/lm-sensors/
 LM_SENSORS_DIR:=$(BUILD_DIR)/lm_sensors-$(LM_SENSORS_VERSION)
 LM_SENSORS_CAT:=$(ZCAT)