libevent: only install event_rpcgen.py if python support is enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 19 Sep 2009 19:31:57 +0000 (21:31 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 19 Sep 2009 19:31:57 +0000 (21:31 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libevent/libevent.mk

index c63dbdb441b7e05141b944e8cfb12029b762d05a..f71bf9a113e499676a6540ebd3c1e7c0d012a3f5 100644 (file)
@@ -13,3 +13,11 @@ LIBEVENT_INSTALL_STAGING = YES
 LIBEVENT_INSTALL_TARGET = YES
 
 $(eval $(call AUTOTARGETS,package,libevent))
+
+ifneq ($(BR2_PACKAGE_PYTHON),y)
+# libevent installs a python script to target - get rid of it if
+# we don't have python support enabled
+$(LIBEVENT_HOOK_POST_INSTALL):
+       rm $(TARGET_DIR)/usr/bin/event_rpcgen.py
+       touch $@
+endif