package/mtd: disable crypto for host
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 18 Jul 2020 09:03:46 +0000 (11:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 18 Jul 2020 13:18:26 +0000 (15:18 +0200)
Commit f1d1347bde41d35630d65898d27d87b99a519cb8 added the optional
openssl dependency for mtd however nothing was done for host-mtd

As a result, crypto support on host-mtd depends on the availability of
host-openssl which is not listed in HOST_MTD_DEPENDENCIES

Moreover, crypto support needs host linux-headers as it includes
<linux/hash_info.h> since version 2.1.2 and
https://github.com/sigma-star/mtd-utils/commit/a739b59efe7996e3bdcbe8b17743dc05ac7c110a

So just disable crypto support for host-mtd

Fixes:
 - http://autobuild.buildroot.org/results/e581bd04e1902476afcdc9d9e34f5fb00fcd31be

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mtd/mtd.mk

index 74b19c7e4a290c52e40875ad4cccdf1f8ebf4685..8220a5ace8b46c105dd02d47ad188d4dd327082a 100644 (file)
@@ -56,6 +56,7 @@ HOST_MTD_DEPENDENCIES = host-zlib host-lzo host-util-linux host-zstd
 HOST_MTD_CONF_OPTS = \
        --with-jffs \
        --with-ubifs \
+       --without-crypto \
        --disable-tests
 
 MKFS_JFFS2 = $(HOST_DIR)/sbin/mkfs.jffs2