core/pkg-utils: check hashes of license files
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 25 Jun 2017 22:03:40 +0000 (00:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Jul 2017 16:03:51 +0000 (18:03 +0200)
This will help catch a change of license even if the filename does
not change.

For now, a missing hash for the license files is not a fatal error, to
let people catch up and add them. When we switch to make it mandatory,
we can simplify the code by just removing the case statement.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Rahul Bedarkar <rahulbedarkar89@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-utils.mk

index e9ac56276fa922cb41c8738e5e7f9d987b0c0ac3..accf48c4643ae02378914709b1fb3d2b872d28ad 100644 (file)
@@ -85,5 +85,10 @@ endef
 
 define legal-license-file # pkgname, pkgname-pkgver, pkgdir, filename, file-fullpath, {HOST|TARGET}
        mkdir -p $(LICENSE_FILES_DIR_$(6))/$(2)/$(dir $(4)) && \
+       { \
+               support/download/check-hash $(3)/$(1).hash $(5) $(4); \
+               ret=$${?}; \
+               case $${ret} in (0|3) ;; (*) exit 1;; esac; \
+       } && \
        cp $(5) $(LICENSE_FILES_DIR_$(6))/$(2)/$(4)
 endef