lighttpd: fix build with pcre support
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 22 Jul 2010 07:08:34 +0000 (09:08 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 22 Jul 2010 07:08:34 +0000 (09:08 +0200)
We need to tell where pcre-config is installed, now that STAGING_DIR/usr/bin
no longer is in the path.

CHANGES
package/lighttpd/lighttpd.mk

diff --git a/CHANGES b/CHANGES
index 28fc5bec5d9435da31f12f56e1a352a64708f38d..a67effe583d582afd43ebcb289874a9c2c6f86b8 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -20,7 +20,7 @@
        dropbear, e2fsprogs, fbv, file, flex, fontconfig, gawk,
        gstreamer, gzip, intltool, ipsec-tools, iptables, libart,
        libcgi, libdrm, libfuse, libgpg-error, libidn, liblockfile,
-       libpng, links, linux-fusion, lmbench, lrzsz, make,
+       libpng, lighttpd, links, linux-fusion, lmbench, lrzsz, make,
        module-init-tools, mysql_client, nbd, ncurses, neon, netcat,
        netperf, ntfsprogs, openssl, php, qt, quagga, sqlite, sdl,
        sdl_mixer, sdl_sound, sdl_ttf, squashfs, tn5250, tremor,
index 1a2562cfcb1396eafdeed031387cc3fe43f32c63..3ac1f07ad1e47c1cec460d3aadf4d6b7caf086a5 100644 (file)
@@ -37,7 +37,7 @@ LIGHTTPD_CONF_OPT += --without-bzip2
 endif
 
 ifeq ($(BR2_PACKAGE_LIGHTTPD_PCRE),y)
-LIGHTTPD_CONF_ENV = PCRE_LIB="-lpcre"
+LIGHTTPD_CONF_ENV = PCRECONFIG=$(STAGING_DIR)/usr/bin/pcre-config
 LIGHTTPD_DEPENDENCIES += pcre
 LIGHTTPD_CONF_OPT += --with-pcre
 else