package/rwmem: new package
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>
Fri, 6 Aug 2021 12:48:54 +0000 (15:48 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 29 Aug 2021 16:55:31 +0000 (18:55 +0200)
rwmem is small tool to read & write device registers. Some of the
features include:

- support mmaped and i2c devices
- addressing with 8/16/32/64 bit addresses
- accessing 8/16/32/64 bit memory locations
- little and big endian addressess and accesses
- bitfields
- address ranges
- register description database

Python bindings are disabled for now.

Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in
package/rwmem/Config.in [new file with mode: 0644]
package/rwmem/rwmem.hash [new file with mode: 0644]
package/rwmem/rwmem.mk [new file with mode: 0644]

index 2dbe511de0e6be8ec91287362a2a525f6739b097..1fc8381048f844901e80f0e75cceeff3ff965c21 100644 (file)
@@ -134,6 +134,7 @@ menu "Debugging, profiling and benchmark"
        source "package/ramsmp/Config.in"
        source "package/ramspeed/Config.in"
        source "package/rt-tests/Config.in"
+       source "package/rwmem/Config.in"
        source "package/sentry-native/Config.in"
        source "package/spidev_test/Config.in"
        source "package/strace/Config.in"
diff --git a/package/rwmem/Config.in b/package/rwmem/Config.in
new file mode 100644 (file)
index 0000000..0fd9142
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_RWMEM
+       bool "rwmem"
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_5
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_FMT
+       select BR2_PACKAGE_INIH
+       help
+         Simple program to read/write from/to any location in memory.
+
+         https://github.com/tomba/rwmem
diff --git a/package/rwmem/rwmem.hash b/package/rwmem/rwmem.hash
new file mode 100644 (file)
index 0000000..9becbc5
--- /dev/null
@@ -0,0 +1,2 @@
+sha256  55d28f029c0cd5c21d3e1c89371e2905d5217f571ef5389ed0fce163804d1c4a  rwmem-c8291705c82bb0686be9adf6a427a2b72114719a.tar.gz
+sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  LICENSE
diff --git a/package/rwmem/rwmem.mk b/package/rwmem/rwmem.mk
new file mode 100644 (file)
index 0000000..24c4e92
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# rwmem
+#
+################################################################################
+
+RWMEM_VERSION = c8291705c82bb0686be9adf6a427a2b72114719a
+RWMEM_SITE = $(call github,tomba,rwmem,$(RWMEM_VERSION))
+RWMEM_LICENSE = GPL-2.0
+RWMEM_LICENSE_FILES = LICENSE
+RWMEM_CONF_OPTS = -Dpyrwmem=disabled
+RWMEM_DEPENDENCIES = host-pkgconf fmt inih
+
+$(eval $(meson-package))