qt: don't enable internal tslib-module debugging
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:33 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:42:51 +0000 (14:42 +0200)
In Qt there are virtually hundreds of internal debug flags like
TSLIBMOUSEHANDLER_DEBUG for every module or even C++ class. There
is no reason to enable a single such flag when Qt is build with
debugging symbols and others not.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index e7c22c3549f2f04ce8d48daea401fd5590a67535..6c73e041e4f36373278c06ba623cfeb559ee946f 100644 (file)
@@ -153,8 +153,6 @@ endif
 ifeq ($(BR2_PACKAGE_QT_MOUSE_TSLIB),y)
 QT_CONFIGURE += -qt-mouse-tslib
 QT_DEP_LIBS+=tslib
-QT_TSLIB_DEB="-D TSLIBMOUSEHANDLER_DEBUG"
-QT_TSLIB_DEB:=$(call qstrip,$(QT_TSLIB_DEB))
 else
 QT_CONFIGURE += -no-mouse-tslib
 endif
@@ -165,7 +163,7 @@ QT_CONFIGURE += -no-mouse-qvfb
 endif
 
 ifeq ($(BR2_PACKAGE_QT_DEBUG),y)
-QT_CONFIGURE+= "-debug $(QT_TSLIB_DEB)"
+QT_CONFIGURE+= -debug
 else
 QT_CONFIGURE+= -release
 endif