new package: phidgetwebservice
authorJonathan Ben Avraham <yba@tkos.co.il>
Wed, 27 Aug 2014 10:18:30 +0000 (13:18 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 28 Aug 2014 06:47:51 +0000 (08:47 +0200)
Signed-off-by: Jonathan Ben-Avraham <yba@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/phidgetwebservice/Config.in [new file with mode: 0644]
package/phidgetwebservice/phidgetwebservice.mk [new file with mode: 0644]

index 2a4d9942079b48e278b7022d18c2ed753a8f4890..883dd66a3cd898f979aed6fc8488ca4b20ae1fb9 100644 (file)
@@ -1040,6 +1040,7 @@ endif
        source "package/openswan/Config.in"
        source "package/openvpn/Config.in"
        source "package/p910nd/Config.in"
+       source "package/phidgetwebservice/Config.in"
        source "package/portmap/Config.in"
        source "package/pppd/Config.in"
        source "package/pptp-linux/Config.in"
diff --git a/package/phidgetwebservice/Config.in b/package/phidgetwebservice/Config.in
new file mode 100644 (file)
index 0000000..7bb6f33
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_PHIDGETWEBSERVICE
+       bool "phidgetwebservice"
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb, libphidget
+       select BR2_PACKAGE_LIBPHIDGET
+       help
+          phidgetwebservice (the Phidget WebService) provides an HTTP
+         front-end to the libphidget device control API. This provides
+         an alternative to the libphidget C linkage interface for
+         controlling locally attached Phidgets USB devices and it also
+         allows you to control Phidget USB devices remotely when the host
+         running the phidgetwebservice has an exposed network interface.
+
+         The phidgetwebservice client program uses the libphidget HTTP
+         functions to send commands to the phidgetwebservice.
+
+         http://phidgets.com/
+
+comment "phidgetwebservice needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/phidgetwebservice/phidgetwebservice.mk b/package/phidgetwebservice/phidgetwebservice.mk
new file mode 100644 (file)
index 0000000..64dfca4
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# phidgetwebservice
+#
+################################################################################
+
+PHIDGETWEBSERVICE_VERSION = 2.1.8.20140319
+PHIDGETWEBSERVICE_SOURCE = phidgetwebservice_$(PHIDGETWEBSERVICE_VERSION).tar.gz
+PHIDGETWEBSERVICE_SITE = http://www.phidgets.com/downloads/libraries/
+PHIDGETWEBSERVICE_DEPENDENCIES = libphidget
+PHIDGETWEBSERVICE_LICENSE = LGPLv3
+PHIDGETWEBSERVICE_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))