Fix soft float options for gcc 4.
authorManuel Novoa III <mjn3@codepoet.org>
Sat, 30 Apr 2005 22:59:05 +0000 (22:59 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Sat, 30 Apr 2005 22:59:05 +0000 (22:59 -0000)
toolchain/gcc/Makefile.in

index c89eb42273cc6a50e68509309243b7b888336529..908a452760aa814ab6f2b09f3cdd742f8d8c21b4 100644 (file)
@@ -21,6 +21,13 @@ SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
 else
 SOFT_FLOAT_CONFIG_OPTION:=--without-float
 endif
+# again... there must be a better way
+ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+endif
+ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
+endif
 TARGET_SOFT_FLOAT:=-msoft-float
 ARCH_FPU_SUFFIX:=_nofpu
 else