dbus-python: fix build after python upgrade
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Jan 2011 08:17:52 +0000 (09:17 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Jan 2011 08:17:52 +0000 (09:17 +0100)
Point it at host-python, and ensure it gets built in advance.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dbus-python/dbus-python.mk

index 5c1245601c452484087c3eb1fb227e350a0612c4..b2e9f56ecd9525309cd73785c9a4bee58b2e97c5 100644 (file)
@@ -10,7 +10,7 @@ DBUS_PYTHON_INSTALL_STAGING = YES
 DBUS_PYTHON_INSTALL_TARGET = YES
 
 DBUS_PYTHON_CONF_ENV = am_cv_pathless_PYTHON=python \
-               ac_cv_path_PYTHON=$(PYTHON_DIR)/hostpython \
+               ac_cv_path_PYTHON=$(HOST_DIR)/usr/bin/python \
                am_cv_python_version=$(PYTHON_VERSION) \
                am_cv_python_platform=linux2 \
                am_cv_python_pythondir=/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
@@ -19,6 +19,6 @@ DBUS_PYTHON_CONF_ENV = am_cv_pathless_PYTHON=python \
 
 DBUS_PYTHON_CONF_OPT = --disable-html-docs --disable-api-docs
 
-DBUS_PYTHON_DEPENDENCIES = dbus-glib python
+DBUS_PYTHON_DEPENDENCIES = dbus-glib python host-python
 
 $(eval $(call AUTOTARGETS,package,dbus-python))