package/alljoyn: use builtin crypto
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 18 Aug 2018 23:32:02 +0000 (01:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 21:10:02 +0000 (23:10 +0200)
Support for OpenSSL 1.1 is broken, use builtin crypto for now like
Debian does:

https://salsa.debian.org/debian-iot-team/alljoyn/alljoyn-core-1504/commit/09d9f916ecb3e0256c5b24ef46af28cdceb4ed1b#8756c63497c8dc39f7773438edf53b220c773f67_27_26

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/alljoyn/Config.in
package/alljoyn/alljoyn.mk

index 6eb417daf86eda3b13b6e120fa11cc8841832db5..781d91bbe94c278a8a56235884dcd0cce2217833 100644 (file)
@@ -7,7 +7,6 @@ config BR2_PACKAGE_ALLJOYN
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_WCHAR
        select BR2_PACKAGE_LIBCAP
-       select BR2_PACKAGE_OPENSSL
        help
          The AllJoyn framework defines a common way for devices and
          apps to communicate with one another regardless of brands,
index 69d5dedc4117f147226893c9efab216cada71631..1281674e3805618c8c3d9daa384d5a79eca6d316 100644 (file)
@@ -11,11 +11,9 @@ ALLJOYN_SITE = https://mirrors.kernel.org/allseenalliance/alljoyn/$(ALLJOYN_REV)
 # See https://allseenalliance.org/alliance/ip-policy
 ALLJOYN_LICENSE = ISC
 
-ALLJOYN_DEPENDENCIES = host-scons libcap openssl
+ALLJOYN_DEPENDENCIES = host-scons libcap
 ALLJOYN_INSTALL_STAGING = YES
 
-ALLJOYN_CRYPTO = openssl
-
 # AllJoyn can be compiled in debug or release mode. By default, AllJoyn is built
 # in debug mode.
 ALLJOYN_VARIANT = release
@@ -39,7 +37,7 @@ ALLJOYN_SCONS_OPTS = \
        CPU=$(ALLJOYN_CPU) \
        VARIANT=$(ALLJOYN_VARIANT) \
        BR=off \
-       CRYPTO=$(ALLJOYN_CRYPTO) \
+       CRYPTO=builtin \
        BINDINGS=$(ALLJOYN_BINDINGS) \
        TARGET_CFLAGS="$(TARGET_CFLAGS)" \
        TARGET_CPPFLAGS="$(TARGET_CPPFLAGS)" \