gnupg: drop mandatory dependency on ncurses
authorTrent Piepho <tpiepho@impinj.com>
Wed, 3 Oct 2018 00:25:48 +0000 (00:25 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 4 Oct 2018 13:35:50 +0000 (15:35 +0200)
This package only needs ncurses when readline support is enabled, as
it's the autoconf macro file for readline (used by autoconf to create
the gnupg configure script) that checks for and pulls in ncurses.

Since readline already depends on ncurses, gnupg need only depend on
readline (when enabled).

The host package always forces readline support off, so the
host-ncurses dependency can be removed entirely.

Signed-off-by: Trent Piepho <tpiepho@impinj.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gnupg/Config.in
package/gnupg/gnupg.mk

index 7c316122984ef31157bcdab6552f8f5e87ff7f97..2db46318f1fd4d11a0fdcb2c756d0cc55b9096ac 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_GNUPG
        bool "gnupg"
        depends on !BR2_PACKAGE_GNUPG2
        select BR2_PACKAGE_ZLIB
-       select BR2_PACKAGE_NCURSES
        help
          GnuPG is the GNU project's complete and free implementation
          of the OpenPGP standard as defined by RFC4880. GnuPG allows
index ac9047894d4d7dbd6436c3e81783fa4ee920db13..bedcf6c985cda3245cc879e22b7fb79bdf94f3b3 100644 (file)
@@ -9,7 +9,7 @@ GNUPG_SOURCE = gnupg-$(GNUPG_VERSION).tar.bz2
 GNUPG_SITE = https://gnupg.org/ftp/gcrypt/gnupg
 GNUPG_LICENSE = GPL-3.0+
 GNUPG_LICENSE_FILES = COPYING
-GNUPG_DEPENDENCIES = zlib ncurses $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+GNUPG_DEPENDENCIES = zlib $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 GNUPG_CONF_ENV = ac_cv_sys_symbol_underscore=no
 GNUPG_CONF_OPTS = \
        --disable-rpath \
@@ -18,7 +18,7 @@ GNUPG_CONF_OPTS = \
        --enable-sha256 \
        --enable-sha512
 
-HOST_GNUPG_DEPENDENCIES = host-zlib host-ncurses
+HOST_GNUPG_DEPENDENCIES = host-zlib
 HOST_GNUPG_CONF_OPTS = \
        --disable-rpath \
        --enable-minimal \