samba4: bump to version 4.5.4
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 24 Jan 2017 10:39:39 +0000 (07:39 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 24 Jan 2017 13:02:35 +0000 (14:02 +0100)
Drop libbsd support, it's problematic and doesn't bring in any greater
benefit.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/samba4/0001-disable-libbsd.patch [deleted file]
package/samba4/0001-libreplace-disable-libbsd-support.patch [new file with mode: 0644]
package/samba4/samba4.hash
package/samba4/samba4.mk

diff --git a/package/samba4/0001-disable-libbsd.patch b/package/samba4/0001-disable-libbsd.patch
deleted file mode 100644 (file)
index 67f79d0..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Disable libbsd support, samba4 uses a global config.h for its own
-codebase and that of heimdal (when building with builtin).
-This causes redefinition conflicts for link(2) when both standard unistd.h
-and bsd/unistd.h get included.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura samba-4.2.0rc1.orig/lib/replace/wscript samba-4.2.0rc1/lib/replace/wscript
---- samba-4.2.0rc1.orig/lib/replace/wscript    2014-10-01 06:17:32.000000000 -0300
-+++ samba-4.2.0rc1/lib/replace/wscript 2014-10-01 07:21:13.559498987 -0300
-@@ -282,15 +282,6 @@
-     conf.CHECK_FUNCS('strtouq strtoll __strtoll strtoq memalign posix_memalign')
-     conf.CHECK_FUNCS('prctl')
--    # libbsd on some platforms provides strlcpy and strlcat
--    if not conf.CHECK_FUNCS('strlcpy strlcat'):
--        conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
--                checklibc=True)
--    if not conf.CHECK_FUNCS('getpeereid'):
--        conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
--    if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
--        conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
--
-     conf.CHECK_CODE('''
-                 struct ucred cred;
-                 socklen_t cred_len;
diff --git a/package/samba4/0001-libreplace-disable-libbsd-support.patch b/package/samba4/0001-libreplace-disable-libbsd-support.patch
new file mode 100644 (file)
index 0000000..4d0c770
--- /dev/null
@@ -0,0 +1,41 @@
+From fc0304ba92ec7ae9a2f75fbc31d97fee39d19665 Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Wed, 7 Sep 2016 23:03:43 -0300
+Subject: [PATCH] libreplace: disable libbsd support
+
+Disable libbsd support, samba4 uses a global config.h for its own
+codebase and that of heimdal (when building with builtin).
+This causes redefinition conflicts for link(2) when both standard
+unistd.h and bsd/unistd.h get included.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+ lib/replace/wscript | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+diff --git a/lib/replace/wscript b/lib/replace/wscript
+index 1dfd902..456be9b 100644
+--- a/lib/replace/wscript
++++ b/lib/replace/wscript
+@@ -248,18 +248,6 @@ def configure(conf):
+     conf.CHECK_FUNCS('prctl dirname basename')
+-    # libbsd on some platforms provides strlcpy and strlcat
+-    if not conf.CHECK_FUNCS('strlcpy strlcat'):
+-        conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
+-                checklibc=True)
+-    if not conf.CHECK_FUNCS('getpeereid'):
+-        conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
+-    if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
+-        conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
+-
+-    if not conf.CHECK_FUNCS('closefrom'):
+-        conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
+-
+     conf.CHECK_CODE('''
+                 struct ucred cred;
+                 socklen_t cred_len;
+-- 
+2.7.3
+
index 04b36dc8ad4005ec52e1af81c0abeb786f2b1e19..1148db233800312ba47407e1d8f4bcb72d3944cf 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 10f76fa113213ae512db4a4823351178c93fb6bc95d98d0ebc72e3a74d43386f        samba-4.4.9.tar.gz
+sha256 1800d10ea14cabef67c83cc56a0f37f4f30ba5df218b3a1e7c874069a08c0f40        samba-4.5.4.tar.gz
index 065bf1f9c0ea711e449215f004a11cb14c1930c2..7eacf8a0858e0d253e3a14db349ce13d6470cfd2 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-SAMBA4_VERSION = 4.4.9
+SAMBA4_VERSION = 4.5.4
 SAMBA4_SITE = http://ftp.samba.org/pub/samba/stable
 SAMBA4_SOURCE = samba-$(SAMBA4_VERSION).tar.gz
 SAMBA4_INSTALL_STAGING = YES
@@ -14,7 +14,6 @@ SAMBA4_DEPENDENCIES = \
        host-e2fsprogs host-heimdal host-python \
        e2fsprogs popt python zlib \
        $(if $(BR2_PACKAGE_LIBAIO),libaio) \
-       $(if $(BR2_PACKAGE_LIBBSD),libbsd) \
        $(if $(BR2_PACKAGE_LIBCAP),libcap) \
        $(if $(BR2_PACKAGE_READLINE),readline)