package/lvm2: install udev rules
authorPascal de Bruijn <p.debruijn@unilogic.nl>
Thu, 2 Jan 2020 15:26:45 +0000 (16:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 7 Jan 2020 20:23:13 +0000 (21:23 +0100)
Without the device-mapper udev rules, dm devices will not get a proper
symlink like /dev/disk/by-label/LABEL, which in turn causes fstab
LABEL= mounts to fails.

And by extension causes shenanigans with systemd, where it will
unmount a manually mounted disk because it can't resolve the label.

Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lvm2/lvm2.mk

index 14575668a5b4b5b1e94f314e6a7d1633795f056e..3da713fe83c14d1ae4454249b2588043fa3c45f9 100644 (file)
@@ -31,6 +31,10 @@ LVM2_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
 # package/readline is GPL-3.0+, so not license compatible
 LVM2_CONF_OPTS += --disable-readline
 
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+LVM2_CONF_OPTS += --enable-udev_rules
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
 LVM2_CONF_OPTS += --enable-selinux
 LVM2_DEPENDENCIES += libselinux