php: allow cache for strcasestr test
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 9 Apr 2015 01:32:30 +0000 (22:32 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Apr 2015 09:54:55 +0000 (11:54 +0200)
Fileinfo does an AC_TRY_RUN to test for strcasestr without allowing a
canned response, hence breaking cross-compiles. Use AC_CACHE_VAL. Fixes:
http://autobuild.buildroot.net/results/10a/10ae44cbc7c0c8e6f1ac54dae4c9d94c703aa3dd/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/0005-ac-cache-strcasestr.patch [new file with mode: 0644]
package/php/php.mk

diff --git a/package/php/0005-ac-cache-strcasestr.patch b/package/php/0005-ac-cache-strcasestr.patch
new file mode 100644 (file)
index 0000000..8a8c5d8
--- /dev/null
@@ -0,0 +1,24 @@
+Allow cache answer for strcasestr discovery.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura php-5.6.7.orig/ext/fileinfo/config.m4 php-5.6.7/ext/fileinfo/config.m4
+--- php-5.6.7.orig/ext/fileinfo/config.m4      2015-04-08 22:19:45.798770792 -0300
++++ php-5.6.7/ext/fileinfo/config.m4   2015-04-08 22:26:33.110654338 -0300
+@@ -14,6 +14,7 @@
+     libmagic/readcdf.c libmagic/softmagic.c"
+   AC_MSG_CHECKING([for strcasestr])
++  AC_CACHE_VAL(ac_cv_func_strcasestr,
+   AC_TRY_RUN([
+ #include <string.h>
+ #include <strings.h>
+@@ -46,7 +47,7 @@
+     AC_MSG_RESULT(no)
+     AC_MSG_NOTICE(using libmagic strcasestr implementation)
+     libmagic_sources="$libmagic_sources libmagic/strcasestr.c"
+-  ])
++  ]))
+   PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+   PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
index f3556327ab07e79fe11e2100debe5a116ba6497e..1a5e084f8f876ab57bb257b0ca2aab524f4dedf4 100644 (file)
@@ -20,7 +20,9 @@ PHP_CONF_OPTS = \
        --without-pear \
        --with-config-file-path=/etc \
        --disable-rpath
-PHP_CONF_ENV = EXTRA_LIBS="$(PHP_EXTRA_LIBS)"
+PHP_CONF_ENV = \
+       ac_cv_func_strcasestr=yes \
+       EXTRA_LIBS="$(PHP_EXTRA_LIBS)"
 
 # PHP can't be AUTORECONFed the standard way unfortunately
 PHP_DEPENDENCIES += host-autoconf host-automake host-libtool