package/xtables-addons: require kernel modules from Kconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 10 Dec 2015 18:53:19 +0000 (19:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Dec 2015 22:53:04 +0000 (23:53 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xtables-addons/Config.in
package/xtables-addons/xtables-addons.mk

index a68761810bd39c4a0b34a95eb4fdcd9adcd853df..45385196094dc0ec502e73730c5fb80b8fbdf3dd 100644 (file)
@@ -10,6 +10,7 @@ config BR2_PACKAGE_XTABLES_ADDONS
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on !BR2_STATIC_LIBS # extensions are .so
        select BR2_PACKAGE_IPTABLES
+       select BR2_LINUX_NEEDS_MODULES # not using kernel-module infra
        help
          Xtables-addons is the successor to patch-o-matic(-ng).
          Likewise, it contains extensions that were not, or are not yet,
index 66e7386271eeb443ca77b1ba3bffe9dd7c3f0538..b4e5992a7ae4f5caa6546ad8927ed2f386d4a122 100644 (file)
@@ -16,12 +16,6 @@ XTABLES_ADDONS_CONF_OPTS = \
        --with-xtables="$(STAGING_DIR)/usr" \
        --with-xtlibdir="/usr/lib/xtables"
 
-# We're building a kernel module without using the kernel-module infra,
-# so we need to tell we want module support in the kernel
-ifeq ($(BR2_PACKAGE_XTABLES_ADDONS),y)
-LINUX_NEEDS_MODULES = y
-endif
-
 # geoip helpers need perl with modules and unzip so disable
 define XTABLES_DISABLE_GEOIP_HELPERS
        $(SED) 's/ geoip//' $(@D)/Makefile.in