Makefile.autotools.in: Get my $(Q)'s in the correct place
authorDaniel Laird <danieljlaird@hotmail.com>
Fri, 19 Sep 2008 14:43:50 +0000 (14:43 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Fri, 19 Sep 2008 14:43:50 +0000 (14:43 -0000)
Minor fix for Makefile.autotools.in that deals with the packages
that use AUTOCONF to regenerate configure etc.
(my mistake to start with)

Daniel Laird

package/Makefile.autotools.in

index 5f2246e8400f225fa4517ecf0add34f39b9d3f35..9c16972827c2d4408ffaea64acd72e70bb9d4fd9 100644 (file)
@@ -202,8 +202,8 @@ $(BUILD_DIR)/%/.stamp_autoconfigured:
        $(call MESSAGE,"Running autoreconf")
        $(Q)cd $(@D)/$($(PKG)_SUBDIR) && $(AUTORECONF)
 # if the package uses libtool, patch it for cross-compiling in buildroot
-       if test "$($(PKG)_LIBTOOL_PATCH)" = "YES"; then \
-       $(Q)for i in `find $(@D)/$($(PKG)_SUBDIR) -name ltmain.sh`; do \
+       $(Q)if test "$($(PKG)_LIBTOOL_PATCH)" = "YES"; then \
+               for i in `find $(@D)/$($(PKG)_SUBDIR) -name ltmain.sh`; do \
                toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
                done \
        fi