qt5connectivity: install examples
authorMatt Kraai <kraai@ftbfs.org>
Wed, 7 Dec 2016 15:11:30 +0000 (07:11 -0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 7 Dec 2016 22:32:56 +0000 (23:32 +0100)
Signed-off-by: Matt Kraai <kraai@ftbfs.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5connectivity/qt5connectivity.mk

index 0f7257d3906e2bfc4cfb81eb61a760a9fb8c47dd..bcbdd2ed8b4a038c46cd858f356bab51ae7e3f12 100644 (file)
@@ -54,12 +54,22 @@ define QT5CONNECTIVITY_INSTALL_TARGET_BLUETOOTH
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Bluetooth.so.* $(TARGET_DIR)/usr/lib
        cp -dpf $(STAGING_DIR)/usr/bin/sdpscanner $(TARGET_DIR)/usr/bin
 endef
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5CONNECTIVITY_INSTALL_TARGET_BLUETOOTH_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/bluetooth $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
 endif
 
 ifeq ($(BR2_PACKAGE_NEARD),y)
 define QT5CONNECTIVITY_INSTALL_TARGET_NFC
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Nfc.so.* $(TARGET_DIR)/usr/lib
 endef
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5CONNECTIVITY_INSTALL_TARGET_NFC_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/nfc $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
 endif
 
 define QT5CONNECTIVITY_INSTALL_TARGET_CMDS
@@ -67,6 +77,8 @@ define QT5CONNECTIVITY_INSTALL_TARGET_CMDS
        $(QT5CONNECTIVITY_INSTALL_TARGET_NFC)
        $(QT5CONNECTIVITY_INSTALL_TARGET_BLUETOOTH_QMLS)
        $(QT5CONNECTIVITY_INSTALL_TARGET_NFC_QMLS)
+       $(QT5CONNECTIVITY_INSTALL_TARGET_BLUETOOTH_EXAMPLES)
+       $(QT5CONNECTIVITY_INSTALL_TARGET_NFC_EXAMPLES)
 endef
 
 $(eval $(generic-package))