package/gobject-introspection: fix datarootdir
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 8 Aug 2021 10:16:50 +0000 (12:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Aug 2021 20:25:37 +0000 (22:25 +0200)
datarootdir has been removed since version 1.66 and
https://gitlab.gnome.org/GNOME/gobject-introspection/-/commit/a88b1ac548516ab25140a2e9dea8cac894bbac93
resulting in the following build failures with autotools-based
applications using introspection (e.g. libmediaart or libsecret) if
gobject-introspection is not installed on host since commit
abc110e3624aa4e8a9bd8595b3fdc0aec60845e0:

make[3]: *** No rule to make target 'MediaArt-2.0.typelib', needed by 'all'.  Stop.

or

Makefile:2917: /usr/share/gobject-introspection-1.0/Makefile.introspection: No such file or directory

Fixes:
 - http://autobuild.buildroot.org/results/70585b81fd6aa78e2aa6e5173f35c0f26a1408a9
 - http://autobuild.buildroot.org/results/95aa8e189f3326ecae6133e298c56ffcbbc3198f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gobject-introspection/gobject-introspection.mk

index d8138b2e96c0bf53edd05fc305ac74e5e0e19d83..fbc545b3c709d42ec8c819c540f4200b135ebbbd 100644 (file)
@@ -116,12 +116,12 @@ define GOBJECT_INTROSPECTION_INSTALL_WRAPPERS
 
        # Gobject-introspection installs Makefile.introspection in
        # $(STAGING_DIR)/usr/share which is needed for autotools-based programs to
-       # build .gir and .typelib files. Unfortuantly, gobject-introspection-1.0.pc
+       # build .gir and .typelib files. Unfortunately, gobject-introspection-1.0.pc
        # uses $(prefix)/share as the directory, which
        # causes the host /usr/share being used instead of $(STAGING_DIR)/usr/share.
-       # Change datarootdir to $(libdir)/../share which will prefix $(STAGING_DIR)
+       # Change datadir to $(libdir)/../share which will prefix $(STAGING_DIR)
        # to the correct location.
-       $(SED) "s%datarootdir=.*%datarootdir=\$${libdir}/../share%g" \
+       $(SED) "s%datadir=.*%datadir=\$${libdir}/../share%g" \
                $(STAGING_DIR)/usr/lib/pkgconfig/gobject-introspection-1.0.pc
 
        # By default, girdir and typelibdir use datadir and libdir as their prefix,