webp: add libfreeglut optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 2 Dec 2017 14:03:07 +0000 (15:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Dec 2017 14:23:40 +0000 (15:23 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webp/webp.mk

index 8999720399e1e81485cf4e991db5023ea33430d9..e86e798d9db6996cda2f1d343569f93470f10b17 100644 (file)
@@ -36,6 +36,13 @@ else
 WEBP_CONF_OPTS += --disable-gif
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFREEGLUT),y)
+WEBP_DEPENDENCIES += libfreeglut
+WEBP_CONF_OPTS += --enable-gl
+else
+WEBP_CONF_OPTS += --disable-gl
+endif
+
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 WEBP_DEPENDENCIES += libpng
 WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config