package/qemu: fix build of host variant
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 8 Sep 2016 18:46:58 +0000 (20:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Sep 2016 20:13:18 +0000 (22:13 +0200)
The Qemu buildsystem expects that the cpp it is passed can be called
like it were cc: it passes it the '-c' option, which is not allowed by
cpp, but is allowed for cc.

Fix that by overriding CPP when calling configure.

Note: the target variant of Qemu does not build the affected parts (the
PC-BIOS images). This is another problem that should be fixed separately.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qemu/qemu.mk

index 42dd9c2991571aa4bf2ddd095219b9b885cb3976..9815f76cf23855943976c61a171f88435e36f24b 100644 (file)
@@ -110,16 +110,19 @@ HOST_QEMU_OPTS += --enable-vde
 HOST_QEMU_DEPENDENCIES += host-vde2
 endif
 
+# Override CPP, as it expects to be able to call it like it'd
+# call the compiler.
 define HOST_QEMU_CONFIGURE_CMDS
-       cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure    \
-               --target-list="$(HOST_QEMU_TARGETS)"    \
-               --prefix="$(HOST_DIR)/usr"              \
-               --interp-prefix=$(STAGING_DIR)          \
-               --cc="$(HOSTCC)"                        \
-               --host-cc="$(HOSTCC)"                   \
-               --python=$(HOST_DIR)/usr/bin/python2    \
-               --extra-cflags="$(HOST_CFLAGS)"         \
-               --extra-ldflags="$(HOST_LDFLAGS)"       \
+       cd $(@D); $(HOST_CONFIGURE_OPTS) CPP="$(HOSTCC) -E" \
+               ./configure \
+               --target-list="$(HOST_QEMU_TARGETS)" \
+               --prefix="$(HOST_DIR)/usr" \
+               --interp-prefix=$(STAGING_DIR) \
+               --cc="$(HOSTCC)" \
+               --host-cc="$(HOSTCC)" \
+               --python=$(HOST_DIR)/usr/bin/python2 \
+               --extra-cflags="$(HOST_CFLAGS)" \
+               --extra-ldflags="$(HOST_LDFLAGS)" \
                $(HOST_QEMU_OPTS)
 endef