ffmpeg: add commandline programs
authorLuca Ceresoli <luca@lucaceresoli.net>
Mon, 14 Jun 2010 19:41:43 +0000 (21:41 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jun 2010 21:39:15 +0000 (23:39 +0200)
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/ffmpeg/Config.in
package/multimedia/ffmpeg/ffmpeg-0.5.2-fix-sdl-config-search.patch [new file with mode: 0644]
package/multimedia/ffmpeg/ffmpeg.mk

index f60790a731f083f891265d077f77d940fda6e539..16bb32d4f3a947ca1222bb7d1cf60197536aeab4 100644 (file)
@@ -24,4 +24,27 @@ config BR2_PACKAGE_FFMPEG_NONFREE
          allow use of nonfree code, the resulting libs and binaries
          will be unredistributable
 
+config BR2_PACKAGE_FFMPEG_FFMPEG
+       bool "Build ffmpeg (the command line application)"
+       default y
+       help
+         FFmpeg is a very fast video and audio converter.
+         It can also grab from a live audio/video source.
+
+         It is not needed if you want to link the FFmpeg libraries
+         to your application.
+
+config BR2_PACKAGE_FFMPEG_FFPLAY
+       bool "Build ffplay"
+       select BR2_PACKAGE_SDL
+       help
+         FFplay is a very simple and portable media player using the
+         FFmpeg libraries and the SDL library.
+         It is mostly used as a testbed for the various FFmpeg APIs.
+
+config BR2_PACKAGE_FFMPEG_FFSERVER
+       bool "Build ffserver"
+       help
+         FFserver is a streaming server for both audio and video.
+
 endif
diff --git a/package/multimedia/ffmpeg/ffmpeg-0.5.2-fix-sdl-config-search.patch b/package/multimedia/ffmpeg/ffmpeg-0.5.2-fix-sdl-config-search.patch
new file mode 100644 (file)
index 0000000..58d08aa
--- /dev/null
@@ -0,0 +1,17 @@
+Allow FFmpeg's ./configure script to use a custom sdl-config command.
+
+Inspired from:
+http://www.mail-archive.com/uclinux-dist-commits@blackfin.uclinux.org/msg01099.html
+
+diff -u ffmpeg-0.5.2-orig/configure ffmpeg-0.5.2/configure
+--- a/configure
++++ b/configure
+@@ -2066,7 +2066,7 @@
+ disable sdl_too_old
+ disable sdl
+-SDL_CONFIG="${cross_prefix}sdl-config"
++SDL_CONFIG="${SDL_CONFIG-${cross_prefix}sdl-config}"
+ if "${SDL_CONFIG}" --version > /dev/null 2>&1; then
+     sdl_cflags=`"${SDL_CONFIG}" --cflags`
+     temp_cflags $sdl_cflags
index 618a3c40cbba02007f21ac8b03a91b78bbce87da..1f9f47295ffc27eae8105719738a862254a62027 100644 (file)
@@ -12,9 +12,6 @@ FFMPEG_INSTALL_TARGET = YES
 FFMPEG_CONF_OPT = \
        --prefix=/usr           \
        --enable-shared         \
-       --disable-ffmpeg        \
-       --disable-ffplay        \
-       --disable-ffserver      \
        --disable-avfilter      \
        --disable-postproc      \
        --disable-swscale       \
@@ -32,6 +29,26 @@ else
 FFMPEG_CONF_OPT += --disable-nonfree
 endif
 
+ifeq ($(BR2_PACKAGE_FFMPEG_FFMPEG),y)
+FFMPEG_CONF_OPT += --enable-ffmpeg
+else
+FFMPEG_CONF_OPT += --disable-ffmpeg
+endif
+
+ifeq ($(BR2_PACKAGE_FFMPEG_FFPLAY),y)
+FFMPEG_DEPENDENCIES += sdl
+FFMPEG_CONF_OPT += --enable-ffplay
+FFMPEG_CONF_ENV += SDL_CONFIG=$(STAGING_DIR)/usr/bin/sdl-config
+else
+FFMPEG_CONF_OPT += --disable-ffplay
+endif
+
+ifeq ($(BR2_PACKAGE_FFMPEG_FFSERVER),y)
+FFMPEG_CONF_OPT += --enable-ffserver
+else
+FFMPEG_CONF_OPT += --disable-ffserver
+endif
+
 ifeq ($(BR2_PTHREADS_NONE),y)
 FFMPEG_CONF_OPT += --disable-pthreads
 else