ncftp: clarify the NCFTP_RUN_AUTOCONF hook.
authorArnout Vandecappelle <arnout@mind.be>
Tue, 25 Feb 2014 21:01:47 +0000 (22:01 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 25 Feb 2014 21:11:18 +0000 (22:11 +0100)
When I saw this patch it took me a while to figure out how/why it worked,
so let's make life easier for the eventual version bumper to understand
what's going on here.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncftp/ncftp.mk

index 841c82ba1c9bc2103e6d762d201d29eb025a8d22..6ab393430c1c00046aaad42e95c522fd92728630 100644 (file)
@@ -13,10 +13,13 @@ NCFTP_LICENSE_FILES = doc/LICENSE.txt
 
 NCFTP_DEPENDENCIES = host-autoconf
 
+# The bundled configure script is generated by autoconf 2.13 and doesn't
+# detect cross-compilation correctly. Therefore, we have to regenerate it.
+# We need to pass -I because of the non-standard m4 directory name, and
+# none of the other autotools are used, so the below is the easiest.
 define NCFTP_RUN_AUTOCONF
        (cd $(@D); $(HOST_DIR)/usr/bin/autoconf -I$(@D)/autoconf_local/)
 endef
-
 NCFTP_PRE_CONFIGURE_HOOKS += NCFTP_RUN_AUTOCONF
 
 ifeq ($(BR2_PACKAGE_NCFTP_GET),y)