- add CFLAGS_COMBINE check
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 21 Mar 2007 10:55:02 +0000 (10:55 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 21 Mar 2007 10:55:02 +0000 (10:55 -0000)
toolchain/Makefile.in

index 84e2ae42fedd819580a8659eae1b65b5956e230b..ca798bf6bf93d0633c57dc20cb36745316a18213 100644 (file)
@@ -16,6 +16,8 @@ OPTIMIZE_FOR_CPU=$(ARCH)
 
 # late binding check to see if the target cc supports -fwhole-program
 CFLAGS_WHOLE_PROGRAM = $(call cc-option,-fwhole-program,)
+# gcc-3.4 would need -combine, I only support 4.2, which correctly uses '--'
+CFLAGS_COMBINE = $(call cc-option,--combine,)
 
 # gcc has a bunch of needed stuff....
 include toolchain/gcc/Makefile.in