package/kodi: Use i.MX VPU (video codec) when available
authorJulien Boibessot <julien.boibessot@armadeus.com>
Wed, 4 Mar 2015 18:37:22 +0000 (19:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Mar 2015 21:50:12 +0000 (22:50 +0100)
Tested on i.MX6.

[Thomas: drop comment in Config.in help text, hard to maintain for all
platforms.]

Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/kodi.mk
package/openswan/openswan.mk

index 0a6fe7cfcefa45ca3e37c2ad320a1a6a5f4d5718..f40fc313fd6b873ebdec3484b33a997cda9d4976 100644 (file)
@@ -61,6 +61,11 @@ KODI_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads
        LIBS="-lvcos -lvchostif"
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFSLVPUWRAP),y)
+KODI_DEPENDENCIES += libfslvpuwrap
+KODI_CONF_OPTS += --enable-codec=imxvpu
+endif
+
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
 KODI_CONF_OPTS += --enable-libcap
 KODI_DEPENDENCIES += libcap
index ba36f7cb1fa8540848d7d20d0ecdc157f260b3dc..3c878c9c465a0e1491af108493eef40ccbf103bd 100644 (file)
@@ -11,7 +11,7 @@ OPENSWAN_LICENSE_FILES = COPYING LICENSE
 
 OPENSWAN_DEPENDENCIES = host-bison host-flex gmp iproute2
 OPENSWAN_MAKE_OPTS = ARCH=$(BR2_ARCH) CC="$(TARGET_CC)" \
-       USERCOMPILE="$(TARGET_CFLAGS) -fPIE" INC_USRLOCAL=/usr \
+       USERCOMPILE="$(TARGET_CFLAGS)" INC_USRLOCAL=/usr \
        USE_KLIPS=false USE_MAST=false USE_NM=false
 
 ifeq ($(BR2_PACKAGE_LIBCURL),y)