package/bird: add optional protocols
authorAdrien Gallouët <adrien@gallouet.fr>
Wed, 20 Mar 2019 21:09:44 +0000 (21:09 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 26 Mar 2019 18:22:21 +0000 (19:22 +0100)
Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
[Thomas:
 - use proper variable names in .mk file
 - add comment in Config.in]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bird/Config.in
package/bird/bird.mk

index a69551f94ec4024f7efb2058eb33aa5aac82dc76..63170ee470434736d67b0ac25947a7af69031a4c 100644 (file)
@@ -20,4 +20,52 @@ config BR2_PACKAGE_BIRD_CLIENT
        help
          Enable the BIRD client
 
+comment "protocol support"
+
+config BR2_PACKAGE_BIRD_BABEL
+       bool "babel"
+       help
+         Enable Babel protocol.
+
+config BR2_PACKAGE_BIRD_BFD
+       bool "bfd"
+       help
+         Enable BFD protocol.
+
+config BR2_PACKAGE_BIRD_BGP
+       bool "bgp"
+       default y
+       help
+         Enable BGP protocol.
+
+config BR2_PACKAGE_BIRD_MRT
+       bool "mrt"
+       help
+         Enable MRT protocol.
+
+config BR2_PACKAGE_BIRD_OSPF
+       bool "ospf"
+       help
+         Enable OSPFv2 and OSPFv3 protocol.
+
+config BR2_PACKAGE_BIRD_PERF
+       bool "perf"
+       help
+         Enable Perf protocol.
+
+config BR2_PACKAGE_BIRD_PIPE
+       bool "pipe"
+       help
+         Enable Pipe protocol.
+
+config BR2_PACKAGE_BIRD_RADV
+       bool "radv"
+       help
+         Enable RAdv protocol.
+
+config BR2_PACKAGE_BIRD_STATIC
+       bool "static"
+       help
+         Enable Static protocol.
+
 endif
index e165be61c0f93bff7f96c9a406d64504f80f0238..8fe585b935ac361b62f9fbb455a9c46f55bcfc1f 100644 (file)
@@ -17,4 +17,20 @@ else
 BIRD_CONF_OPTS += --disable-client
 endif
 
+# BUG: RIP is mandatory for now
+BIRD_PROTOCOLS = \
+       rip \
+       $(if $(BR2_PACKAGE_BIRD_BFD),bfd) \
+       $(if $(BR2_PACKAGE_BIRD_BABEL),babel) \
+       $(if $(BR2_PACKAGE_BIRD_BGP),bgp) \
+       $(if $(BR2_PACKAGE_BIRD_MRT),mrt) \
+       $(if $(BR2_PACKAGE_BIRD_OSPF),ospf) \
+       $(if $(BR2_PACKAGE_BIRD_PERF),perf) \
+       $(if $(BR2_PACKAGE_BIRD_PIPE),pipe) \
+       $(if $(BR2_PACKAGE_BIRD_RADV),radv) \
+       $(if $(BR2_PACKAGE_BIRD_RIP),rip) \
+       $(if $(BR2_PACKAGE_BIRD_STATIC),static)
+
+BIRD_CONF_OPTS += --with-protocols=$(subst $(space),$(comma),$(strip $(BIRD_PROTOCOLS)))
+
 $(eval $(autotools-package))