Qtopia: don't build sqlite driver when SQL module is disabled.
authorThiago A. Corrêa <thiago.correa@gmail.com>
Wed, 3 Sep 2008 01:09:29 +0000 (01:09 -0000)
committerThiago A. Corrêa <thiago.correa@gmail.com>
Wed, 3 Sep 2008 01:09:29 +0000 (01:09 -0000)
package/qtopia4/qtopia4.mk

index b8afdaa011c90b15d2cb4707a801f26e395f43b5..72632521afe505c2213300a896434651b333d33a 100644 (file)
@@ -182,11 +182,17 @@ QTOPIA4_CONFIGURE+= -qt-sql-psql
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_SQLITE),y)
 QTOPIA4_CONFIGURE+= -qt-sql-sqlite
+else
+QTOPIA4_CONFIGURE+= -no-sql-sqlite
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_SQLITE2),y)
 QTOPIA4_CONFIGURE+= -qt-sql-sqlite2
 endif
+else
 # By default, no SQL driver is turned on by configure.
+# but it seams sqlite isn't disabled despite what says
+# configure --help
+QTOPIA4_CONFIGURE+= -no-sql-sqlite
 endif
 
 ifeq ($(BR2_PACKAGE_QTOPIA4_XMLPATTERNS),y)