qt5base: add OpenSSL support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Mar 2013 09:29:34 +0000 (09:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Mar 2013 21:07:09 +0000 (22:07 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5base/qt5base.mk

index 33555aef32760d1f00bd7d286eca9afdcac06957..736965d368d27a2813e41daef9d5f609ba081224 100644 (file)
@@ -28,7 +28,6 @@ QT5BASE_CONFIGURE_OPTS += \
        -no-nis \
        -no-libudev \
        -no-iconv \
-       -no-openssl \
        -no-fontconfig \
        -no-gif \
        -no-libpng \
@@ -82,6 +81,9 @@ else
 QT5BASE_CONFIGURE_OPTS += -no-xcb
 endif
 
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_OPENSSL),-openssl,-no-openssl)
+QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_OPENSSL),openssl)
+
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK)    += Qt5Network