package/freerdp: do not use SSE2 extensions when not available
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 27 Dec 2014 18:16:07 +0000 (19:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 18:59:45 +0000 (19:59 +0100)
Do not let FreeRDP decide whether it can use SE2 opcodes, it may well
fail to do so, because the heuristic is not working for
cross-compilation.

Also, we do have a Kconfig option stating whether we have SSE2 or not,
so reuse that.

Similar to the recent ARM+Neon fix.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freerdp/freerdp.mk

index c9396b5ec6f9b2322a9107dc386f326c78f52580..a703500b6fdb2c27d8632c876656179f29fab846 100644 (file)
@@ -69,4 +69,10 @@ else
 FREERDP_CONF_OPTS += -DWITH_NEON=OFF
 endif
 
+ifeq ($(BR2_X86_CPU_HAS_SSE2),y)
+FREERDP_CONF_OPTS += -DWITH_SSE2=ON
+else
+FREERDP_CONF_OPTS += -DWITH_SSE2=OFF
+endif
+
 $(eval $(cmake-package))